Bug 1506475 - [modularity] inconsistent ordering in module listing
Summary: [modularity] inconsistent ordering in module listing
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 27
Hardware: Unspecified Unspecified
low
low
Target Milestone: ---
Assignee: Martin Hatina
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: dnf-modularity
TreeView+ depends on / blocked
 
Reported: 2017-10-26 07:58 UTC by Karel Srot
Modified: 2018-06-28 08:05 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-13 08:03:28 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karel Srot 2017-10-26 07:58:57 UTC
dnf-2 and dnf-3 differs in module order 

[root@7ac3247f4757 /]# rpm -q dnf
dnf-2.7.5-6.fc26.modularity.1.3fb9e5c.git.8056.9361b1aNone.noarch
[root@7ac3247f4757 /]# dnf-2 module list --enabled ModuleA
Last metadata expiration check: 0:06:58 ago on Thu Oct 26 07:50:53 2017.
modularityABDE
Name                 Stream             Version             Profiles                            
ModuleA              f26                1                   client, default, ...                
ModuleA              f26                2                   client [i], default, ...            

Hint: [d]efault, [i]nstalled, [l]ocked
[root@7ac3247f4757 /]# dnf-3 module list --enabled ModuleA
Last metadata expiration check: 0:07:00 ago on Thu Oct 26 07:50:53 2017.
modularityABDE
Name                 Stream             Version             Profiles                            
ModuleA              f26                2                   client [i], default, ...            
ModuleA              f26                1                   client, default, ...                

Hint: [d]efault, [i]nstalled, [l]ocked


This is an issue for upstream test dnf-module-list-1 which matches the cmd output.

Comment 1 Martin Hatina 2017-10-27 06:54:47 UTC
Fixed by https://github.com/rpm-software-management/dnf/pull/971

Comment 2 Jaroslav Mracek 2018-06-28 08:05:11 UTC
The issue is solved by dnf-3.0.1-1 that was released into rawhide.


Note You need to log in before you can comment on or make changes to this bug.