Bug 1506536 - screen transition of nmtui in KDE is slow
Summary: screen transition of nmtui in KDE is slow
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1656436
TreeView+ depends on / blocked
 
Reported: 2017-10-26 09:40 UTC by jigar
Modified: 2019-08-06 13:16 UTC (History)
12 users (show)

Fixed In Version: NetworkManager-1.18.0-0.3.20190408git43d9187c14.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 13:16:20 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2302 None None None 2019-08-06 13:16:36 UTC

Description jigar 2017-10-26 09:40:07 UTC
Description of problem: This problem occurs if you log in to KDE desktop by root user, start Konsole terminal emulator, and use nmtui.

Version-Release number of selected component (if applicable): NetworkManager-tui-1.8.0-11.el7_4.x86_64

How reproducible: Always

Steps to Reproduce:
1) Log in to KDE desktop by root user 
2) start Konsole terminal emulator
3) Run nmtui as follows :

  i) Press Enter on "Edit a connection"  
 ii) Press Enter on "<Edit...>"
iii) Click "Allow once" 2 or 3 times on KDE Wallet dialog
 iv) It will take about 1 minutes to transit to "Edit connection" screen.

Actual results: screen transition is slow


Expected results: screen transition shouldn't take significant time

Additional Info : 

1) It does NOT occur if logging in to KDE desktop by normal user and become
root user by "su -" and run nmtui. (In this case, KDE Wallet dialog is not displayed.)

2) It does NOT occur if using GNOME desktop instead of KDE.

3) Disabling KDE Wallet does not work.
(KDE Wallet can be disabled by System Settings -> Account Details -> KDE Wallet
-> Uncheck "Enable the KDE Wallet subsystem" -> Click "Apply")

Comment 2 Beniamino Galvani 2017-10-30 13:07:37 UTC
When running KDE, plasma-nm registers itself as a NM secret agent.

When the connection is opened for edit by nmtui, NetworkManager requests the connection's secret to the registered secret agents. It seems that on RHEL plasma-nm doesn't respond at GetSecret() requests from NM and makes them time out, causing the delay in nmtui.

For this reason I'm reassigning this bug to plasma-nm for investigation.

Comment 11 Beniamino Galvani 2019-04-01 15:10:24 UTC
https://github.com/NetworkManager/NetworkManager/pull/327

Comment 14 Vladimir Benes 2019-05-28 10:44:20 UTC
we have no way to verify this but the reporter said, it's far better now as ipv4 and proxy are not asking for secrets anymore.

Comment 16 errata-xmlrpc 2019-08-06 13:16:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2302


Note You need to log in before you can comment on or make changes to this bug.