Bug 1506609 - Fails to update XPS13 firmware
Summary: Fails to update XPS13 firmware
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fwupdate
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1511544 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-26 12:44 UTC by Alexander Larsson
Modified: 2018-01-12 01:51 UTC (History)
16 users (show)

Fixed In Version: fwupdate-10-0.2.fc27 fwupdate-10-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-12 01:51:59 UTC
Type: Bug


Attachments (Terms of Use)

Description Alexander Larsson 2017-10-26 12:44:26 UTC
When i run fwupdmgr update i get:

Downloading 0.2.2.1 for XPS 13 9360 System Firmware...
Updating 0.2.2.1 on XPS 13 9360 System Firmware...
Decompressing…         [  -                                     ]
Scheduling…            [    \                                   ]UEFI firmware update failed:
{error #0} /builddir/build/BUILD/fwupdate-9/linux/libfwup.c:1224 get_fd_and_media_path(): mkostemps(/boot/efi/EFI//boot/efi/EFI/fedora/fw/fw/fwupdate-LdGWJ1.cap) failed: No such file or directory 


Clearly there is something wrong with this path, it seems to duplicate /boot/efi...

Comment 1 Alexander Larsson 2017-10-26 12:45:59 UTC
Sorry, got the wrong component first.

Comment 2 Mario Limonciello 2017-10-31 15:19:09 UTC
*** Bug 1495137 has been marked as a duplicate of this bug. ***

Comment 3 Thorsten Leemhuis 2017-10-31 15:27:59 UTC
> Mario Limonciello 2017-10-31 11:19:09 EDT
> Duplicate of this bug: 1495137

FWIW: Don't we normally mark newer bugs as duplicate of older bugs? One reason for that afaics: We lost two reporters that where CCed to Bug 1495137 but are not CCed here now (I was CCed automatically) :-/ #sigh #whatever

Comment 4 Mario Limonciello 2017-11-09 17:19:42 UTC
@Thorsten,
Sorry about that.  This bug was marked for the right component and assigned properly.  I'll double check CC list from that bug.

Comment 5 Alessio 2017-11-11 00:40:15 UTC
*** Bug 1511544 has been marked as a duplicate of this bug. ***

Comment 6 Richard Hughes 2017-11-14 15:57:00 UTC
Should be fixed in https://bodhi.fedoraproject.org/updates/FEDORA-2017-10b2acfd49, thanks Peter.

Comment 7 Alessio 2017-11-15 21:29:32 UTC
I'm still unable to perform the upgrade.
With sudo fwupdmgr update, an entry in the efi boot manager is created:

alessio@pbale ~> sudo efibootmgr -v              
BootNext: 0003
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0000,0001,0003
Boot0000* Fedora	PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)/NVMe(0x1,00-08-0D-03-00-1C-2E-E8)/HD(1,GPT,f66f1a9c-d68e-4348-b3fd-ebb06670da90,0x800,0x64000)/File(\EFI\fedora\shimx64.efi)
Boot0001* zzz	PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)/NVMe(0x1,00-08-0D-03-00-1C-2E-E8)/HD(1,GPT,f66f1a9c-d68e-4348-b3fd-ebb06670da90,0x800,0x64000)/File(\EFI\BOOT\BOOTX64.EFI)
Boot0002* Fedora	HD(1,GPT,f66f1a9c-d68e-4348-b3fd-ebb06670da90,0x800,0x64000)/File(\EFI\fedora\shimx64.efi)
Boot0003* Linux-Firmware-Updater \fwupx64.efi	HD(1,GPT,f66f1a9c-d68e-4348-b3fd-ebb06670da90,0x800,0x64000)/File(\EFI\fedora\shimx64.efi)\.f.w.u.p.x.6.4...e.f.i...


Rebooting the pc, before the grub menu, a line telling that an update was found appears, the Dell logo appears again, but at the end of the day I'm still on the old version

alessio@pbale ~> fwupdmgr get-devices
...
XPS 13 9360 System Firmware
  DeviceId:             UEFI-5ffdbc0d-f340-441c-a803-8439c8c0ae10-dev0
  Guid:                 5ffdbc0d-f340-441c-a803-8439c8c0ae10
  Plugin:               uefi
  Flags:                internal|updatable|require-ac|supported|registered|needs-reboot
  Version:              0.1.3.7
  VersionLowest:        0.1.3.7
  Icon:                 computer
  Created:              2017-11-15
  Modified:             2017-11-15
...

While 

alessio@pbale ~> sudo fwupdmgr get-releases UEFI-5ffdbc0d-f340-441c-a803-8439c8c0ae10-dev0
XPS 13 9360 System Firmware:
Version:                 0.1.2.3
Remote:                  lvfs
URI:                     https://fwupd.org/downloads/95b37375ce6af8a15abffe11155601a7d2ba03ba-firmware.cab
Checksum:                SHA1(c04856f7dfe57e98601d69eea88c752d1f4bef21)

Version:                 0.1.3.2
Remote:                  lvfs
URI:                     https://fwupd.org/downloads/7b1c5061458f748d5900a47159617f8bda413195-firmware.cab
Checksum:                SHA1(0de3661dbeba8134520c9852b9762a066c326d91)

Version:                 0.1.3.5
Remote:                  lvfs
URI:                     https://fwupd.org/downloads/4106f6f9528b7bd785ec0735c56d1876f3c8eb9f-firmware_XPS_9360_1_3_5.cab
Checksum:                SHA1(f76859b20123e5543f7e92b3f021f46867729116)

Version:                 0.1.3.7
Remote:                  lvfs
URI:                     https://fwupd.org/downloads/8fc8f1e3af81c00490a797def69ea5b8186d69b4-firmware_XPS_9360_1_3_7.cab
Checksum:                SHA1(b3740b21e5b02f7018c8c8ec9d17b765af9a2d4a)

Version:                 0.2.1.0
Remote:                  lvfs
URI:                     https://fwupd.org/downloads/06d4df9ec3817be64a0d4b55927a687ab0e2cb66-firmware_XPS_9360_2_1_0.cab
Checksum:                SHA1(cef6088e1104941d8ed009d27140c47b5903b13c)

Version:                 0.2.2.1
Remote:                  lvfs
URI:                     https://fwupd.org/downloads/4efcda1e3a49b1a82121dc155d73703bcec05e31-firmware_XPS_9360_2_2_1.cab
Checksum:                SHA1(52b875e4eab8bf4c384861b9cd878c62e8fc899f)

Version:                 0.2.3.1
Remote:                  lvfs
URI:                     https://fwupd.org/downloads/6fd391badc79a4d9a2c9916073f6941f885a22fd-firmware_XPS_9360_2_3_1.cab
Checksum:                SHA1(18d9501fc82e8c39acb57693e2c6ad60a2712f9a)


Is not 0.2.3.1 the latest version available?
Or at least, issuing sudo fwupdmgr update -vv, the advised downloaded version is Downloading 0.2.1.0 for XPS 13 9360 System Firmware...
Why I'm stuck on 0.1.3.7?

Comment 8 Fedora Update System 2017-11-15 23:51:55 UTC
efivar-32-2.fc27, fwupdate-10-0.2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-10b2acfd49

Comment 9 Richard Hughes 2017-11-16 10:25:31 UTC
Alessio, first make sure you're on fwupd >= 1.0.0 then can you share the output of "fwupdmgr get-updates"? Thanks.

Comment 10 Alessio 2017-11-16 10:37:12 UTC
(In reply to Richard Hughes from comment #9)
> Alessio, first make sure you're on fwupd >= 1.0.0 then can you share the
> output of "fwupdmgr get-updates"? Thanks.

fwupd-1.0.1-3.fc27.x86_64

alessio@pbale ~> fwupdmgr get-updates
XPS 13 9360 System Firmware has firmware updates:
GUID:                    5ffdbc0d-f340-441c-a803-8439c8c0ae10
ID:                      com.dell.uefi5ffdbc0d.firmware
Update Version:          0.2.1.0
Update Remote ID:        lvfs
Update Checksum:         SHA1(cef6088e1104941d8ed009d27140c47b5903b13c)
Update Location:         https://fwupd.org/downloads/06d4df9ec3817be64a0d4b55927a687ab0e2cb66-firmware_XPS_9360_2_1_0.cab
ID:                      com.dell.uefi5ffdbc0d.firmware
Update Version:          0.2.2.1
Update Remote ID:        lvfs
Update Checksum:         SHA1(52b875e4eab8bf4c384861b9cd878c62e8fc899f)
Update Location:         https://fwupd.org/downloads/4efcda1e3a49b1a82121dc155d73703bcec05e31-firmware_XPS_9360_2_2_1.cab
ID:                      com.dell.uefi5ffdbc0d.firmware
Update Version:          0.2.3.1
Update Remote ID:        lvfs
Update Checksum:         SHA1(18d9501fc82e8c39acb57693e2c6ad60a2712f9a)
Update Location:         https://fwupd.org/downloads/6fd391badc79a4d9a2c9916073f6941f885a22fd-firmware_XPS_9360_2_3_1.cab

Comment 11 Richard Hughes 2017-11-16 10:48:39 UTC
Alessio, and what does "fwupdmgr update --verbose" output?

Comment 12 Jonathan Haas 2017-11-16 10:49:14 UTC
Because of this bug, I have installed the latest update manually. How can I verify that the update works without waiting for the next bios update?

FWIW I also couldn't find a commit that seemed relevant to the problem.

Comment 13 Alessio 2017-11-16 10:52:16 UTC
(In reply to Richard Hughes from comment #11)
> Alessio, and what does "fwupdmgr update --verbose" output?

alessio@pbale ~> fwupdmgr update --verbose
Downloading 0.2.1.0 for XPS 13 9360 System Firmware...
(fwupdmgr:8063): Fu-DEBUG: creating path /home/alessio/.cache/fwupdmgr
(fwupdmgr:8063): Fu-DEBUG: downloading https://fwupd.org/downloads/06d4df9ec3817be64a0d4b55927a687ab0e2cb66-firmware_XPS_9360_2_1_0.cab to /home/alessio/.cache/fwupdmgr/06d4df9ec3817be64a0d4b55927a687ab0e2cb66-firmware_XPS_9360_2_1_0.cab
Fetching firmware https://fwupd.org/downloads/06d4df9ec3817be64a0d4b55927a687ab0e2cb66-firmware_XPS_9360_2_1_0.cab
(fwupdmgr:8063): Fu-DEBUG: ignoring status code 301 (MOVED PERMANENTLY)
(fwupdmgr:8063): Fu-DEBUG: progress: 0%
Downloading…           [-                                      ](fwupdmgr:8063): Fu-DEBUG: progress: 0%
Downloading…           [ -                                     ](fwupdmgr:8063): Fu-DEBUG: progress: 0%
...snip...
(fwupdmgr:8063): Fu-DEBUG: progress: 99%
(fwupdmgr:8063): Fu-DEBUG: progress: 100%
Downloading…           [***************************************]
Updating 0.2.1.0 on XPS 13 9360 System Firmware...
(fwupdmgr:8063): Fwupd-DEBUG: Emitting ::status-changed() [decompressing]
Decompressing…         [    \                                  ](fwupdmgr:8063): Fwupd-DEBUG: Emitting ::status-changed() [idle]
Decompressing…         [***************************************]
(fwupdmgr:8063): Fwupd-DEBUG: Emitting ::status-changed() [waiting-for-auth]
Authenticating…        [     \                                 ](fwupdmgr:8063): Fwupd-DEBUG: Emitting ::status-changed() [idle]
Authenticating…        [***************************************]
(fwupdmgr:8063): Fwupd-DEBUG: Emitting ::status-changed() [scheduling]
Scheduling…            [                 -                     ](fwupdmgr:8063): Fwupd-DEBUG: Emitting ::status-changed() [idle]
Scheduling…            [***************************************]
(fwupdmgr:8063): Fwupd-DEBUG: Emitting ::device-changed(UEFI-5ffdbc0d-f340-441c-a803-8439c8c0ae10-dev0)
(fwupdmgr:8063): Fwupd-DEBUG: Emitting ::changed()

Comment 14 Alessio 2017-11-16 11:24:34 UTC
alessio@pbale ~> sudo efibootmgr -v              
[sudo] password for alessio: 
BootNext: 0003
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0000,0001,0003
Boot0000* Fedora	PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)/NVMe(0x1,00-08-0D-03-00-1C-2E-E8)/HD(1,GPT,f66f1a9c-d68e-4348-b3fd-ebb06670da90,0x800,0x64000)/File(\EFI\fedora\shimx64.efi)
Boot0001* zzz	PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)/NVMe(0x1,00-08-0D-03-00-1C-2E-E8)/HD(1,GPT,f66f1a9c-d68e-4348-b3fd-ebb06670da90,0x800,0x64000)/File(\EFI\BOOT\BOOTX64.EFI)
Boot0002* Fedora	HD(1,GPT,f66f1a9c-d68e-4348-b3fd-ebb06670da90,0x800,0x64000)/File(\EFI\fedora\shimx64.efi)
Boot0003* Linux-Firmware-Updater \fwupx64.efi	HD(1,GPT,f66f1a9c-d68e-4348-b3fd-ebb06670da90,0x800,0x64000)/File(\EFI\fedora\shimx64.efi)\.f.w.u.p.x.6.4...e.f.i...

Comment 15 Richard Hughes 2017-11-16 11:25:07 UTC
Hmm, so "alessio@pbale ~> fwupdmgr get-updates" lists the updates backwards :/

That's a different bug, and I can certainly fix that in fwupd.

Comment 16 Richard Hughes 2017-11-16 12:48:24 UTC
Updates being listed backward issue tracked upstream: https://github.com/hughsie/fwupd/issues/319

Comment 17 Kamil Grzebien 2017-11-16 21:04:22 UTC
I've update packages and tried on my XPS 9560 and problem doesn't seem to be solved:

[ci@XPS ~]$ rpm -q fwupdate
fwupdate-10-0.2.fc27.x86_64

[ci@XPS ~]$ sudo fwupdmgr update -v
Downloading 0.1.5.0 for XPS 15 9560 System Firmware...
(fwupdmgr:27068): Fu-DEBUG: creating path /root/.cache/fwupdmgr
(fwupdmgr:27068): Fu-DEBUG: skpping download as file already exists
Updating 0.1.5.0 on XPS 15 9560 System Firmware...
(fwupdmgr:27068): Fwupd-DEBUG: Emitting ::status-changed() [decompressing]
Decompressing…         [  -                                     ](fwupdmgr:27068): Fwupd-DEBUG: Emitting ::status-changed() [idle]
 
(fwupdmgr:27068): Fwupd-DEBUG: Emitting ::status-changed() [scheduling]
Scheduling…            [    \                                   ]UEFI firmware update failed:
{error #0} /builddir/build/BUILD/fwupdate-9/linux/libfwup.c:1224 get_fd_and_media_path(): mkostemps(/boot/efi/EFI//boot/efi/EFI/fedora/fw/fw/fwupdate-q87eCc.cap) failed: No such file or directory

Comment 18 Mario Limonciello 2017-11-16 22:15:25 UTC
@Kamil,

Can you try to clear the existing variables using the systemd unit and try again?

IIRC something like this (sorry not on Fedora at the moment to confirm paths):
# rm -f /var/cache/fwupdate/done
# systemctl start fwupdate-cleanup.service

If that works(fixes the double path), then pjones needs to add something to the rpm post to cleanup on upgrade from people who had this borked path before.

Comment 19 Kamil Grzebien 2017-11-17 12:05:16 UTC
@Mario thanks for a hint

At first fwupdate-cleanup.service didn't run as couldn't create file so I updated  /usr/libexec/fwupdate/cleanup from /fwupdate/done to /var/cache/fwupdate/done

After running cleanup service indeed I can run update process:

[ci@XPS ~]$ sudo fwupdmgr update -v
[sudo] password for ci: 
Downloading 0.1.5.0 for XPS 15 9560 System Firmware...
(fwupdmgr:3286): Fu-DEBUG: creating path /root/.cache/fwupdmgr
(fwupdmgr:3286): Fu-DEBUG: skpping download as file already exists
Updating 0.1.5.0 on XPS 15 9560 System Firmware...
(fwupdmgr:3286): Fwupd-DEBUG: Emitting ::status-changed() [decompressing]
Decompressing…         [  -                                     ](fwupdmgr:3286): Fwupd-DEBUG: Emitting ::status-changed() [idle]
 
(fwupdmgr:3286): Fwupd-DEBUG: Emitting ::status-changed() [scheduling]
Scheduling…            [              /                         ](fwupdmgr:3286): Fwupd-DEBUG: Emitting ::status-changed() [idle]
 
(fwupdmgr:3286): Fwupd-DEBUG: Emitting ::device-changed((null))
(fwupdmgr:3286): Fwupd-DEBUG: Emitting ::changed()


Once I restart machine new EFI entry is there and I can see prompt
Found update fwupdate-....
File \EFI\fedora\fw\fwupdate-xROH20.cap searched

After all firmware is not updated. Is there anything I'm missing? Where to check logs of update process to see what happened?

Comment 20 Mario Limonciello 2017-11-17 15:27:22 UTC
Kamil,

Thanks so there are a few problems at play here that need to be fixed by pjones.  3 separate problems.

1) The path in the cleanup service is wrong (as you outlined).  That would explain why it never ran in the first place when you first installed Fedora.

2) The "done" file needs to be removed and the cleanup service needs to be run again when upgrading from fwupdate 9 to fwupdate 10 since the wrong path is cached.

3) Something is wrong with this new rpm in that it's not actually flashing the BIOS.  It finds the file but doesn't call UpdateCapsule() with the proper payload.

Comment 21 Mario Limonciello 2017-11-17 22:32:45 UTC
(1) and (2) need to be fixed in RPM spec file.

Regarding (3) I believe you can look further into problem via debugging functionality in fwupdate by creating appropriate FWUPDATE_VERBOSE variable.  This should hopefully provide more information on what is going wrong.
https://github.com/rhboot/fwupdate/blob/master/efi/fwupdate.c#L1199

You might be able to create this with something like this:
# touch /sys/firmware/efi/efivars/FWUPDATE_VERBOSE-0abba7dc-e516-4167-bbf5-4d9d1c739416

Comment 22 Fedora Update System 2017-11-21 23:31:31 UTC
efivar-32-2.fc27, fwupdate-10-0.2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Alessio 2017-11-22 08:47:18 UTC
I'm still unable to update XPS13.

Comment 24 Alessio 2017-12-06 09:09:34 UTC
efivar-32-2.fc27.x86_64
fwupdate-10-0.2.fc27.x86_64

# fwupdmgr get-devices
...
XPS 13 9360 System Firmware
  DeviceId:             3f0ecc7823ee99c718693e8ecca38f54e8738dc5
  Guid:                 5ffdbc0d-f340-441c-a803-8439c8c0ae10
  Plugin:               uefi
  Flags:                internal|updatable|require-ac|supported|registered|needs-reboot
  Version:              0.1.3.7
  VersionLowest:        0.1.3.7
  Icon:                 computer
  Created:              2017-12-06
  UpdateState:          success
...


# fwupdmgr get-updates 3f0ecc7823ee99c718693e8ecca38f54e8738dc5
XPS 13 9360 System Firmware has firmware updates:
GUID:                    5ffdbc0d-f340-441c-a803-8439c8c0ae10
ID:                      com.dell.uefi5ffdbc0d.firmware
Update Version:          0.2.3.1
Update Remote ID:        lvfs
Update Checksum:         SHA1(18d9501fc82e8c39acb57693e2c6ad60a2712f9a)
Update Location:         https://fwupd.org/downloads/6fd391badc79a4d9a2c9916073f6941f885a22fd-firmware_XPS_9360_2_3_1.cab
ID:                      com.dell.uefi5ffdbc0d.firmware
Update Version:          0.2.2.1
Update Remote ID:        lvfs
Update Checksum:         SHA1(52b875e4eab8bf4c384861b9cd878c62e8fc899f)
Update Location:         https://fwupd.org/downloads/4efcda1e3a49b1a82121dc155d73703bcec05e31-firmware_XPS_9360_2_2_1.cab
ID:                      com.dell.uefi5ffdbc0d.firmware
Update Version:          0.2.1.0
Update Remote ID:        lvfs
Update Checksum:         SHA1(cef6088e1104941d8ed009d27140c47b5903b13c)
Update Location:         https://fwupd.org/downloads/06d4df9ec3817be64a0d4b55927a687ab0e2cb66-firmware_XPS_9360_2_1_0.cab

# fwupdmgr update 
Downloading 0.2.3.1 for XPS 13 9360 System Firmware...
Updating 0.2.3.1 on XPS 13 9360 System Firmware...
Decompressing…         [***************************************]
Authenticating…        [***************************************]
Scheduling…            [***************************************]

At reboot it seems that an update is detected. The DELL icon appears again, but when Fedora is running, the reported Version is still 0.1.3.7

Comment 25 Max Whittingham 2017-12-18 04:40:30 UTC
I seem to be having the same problem as Alessio. After rebooting, it seems to find the update file but does not update it.

 max  ~  rpm -qa fwupd
fwupd-1.0.2-1.fc27.x86_64

 max  ~  rpm -qa efivar
efivar-32-2.fc27.x86_64

 max  ~  fwupdmgr get-devices
Intel AMT (unprovisioned)
  DeviceId:             088df415cdee883ec89563e41e6d495924250174
  Guid:                 2800f812-b7b4-2d4b-aca8-46e0ff65814c
  Summary:              Hardware and firmware technology for remote out-of-band management
  Plugin:               amt
  Flags:                internal|registered
  Vendor:               Intel Corporation
  Version:              11.7.0
  VersionBootloader:    11.7.0
  Icon:                 computer
  Created:              2017-12-18

XPS 13 9360 System Firmware
  DeviceId:             3f0ecc7823ee99c718693e8ecca38f54e8738dc5
  Guid:                 5ffdbc0d-f340-441c-a803-8439c8c0ae10
  Plugin:               uefi
  Flags:                internal|updatable|require-ac|supported|registered|needs-reboot
  Version:              0.2.3.1
  VersionLowest:        0.2.3.1
  Icon:                 computer
  Created:              2017-12-18

HD Graphics 620
  DeviceId:             ca9f93cb97772027f45ba73c86cf4980fb02745b
  Guid:                 3ec3df3a-2290-56e5-9d2f-eda62e9ab50b
  Plugin:               udev
  Flags:                internal|registered
  Vendor:               Intel Corporation
  VendorId:             PCI:0x8086
  Icon:                 audio-card
  Created:              2017-12-18

 max  ~  fwupdmgr refresh
Fetching metadata https://s3.amazonaws.com/lvfsbucket/downloads/firmware.xml.gz
Downloading…           [***************************************]
Fetching signature https://s3.amazonaws.com/lvfsbucket/downloads/firmware.xml.gz.asc

 max  ~  fwupdmgr get-updates 5ffdbc0d-f340-441c-a803-8439c8c0ae10
XPS 13 9360 System Firmware has firmware updates:
GUID:                    5ffdbc0d-f340-441c-a803-8439c8c0ae10
ID:                      com.dell.uefi5ffdbc0d.firmware
Update Version:          0.2.4.2
Update Remote ID:        lvfs
Update Checksum:         SHA1(c9f29b0a6f252231c122f0b7bcdecf078eed39cd)
Update Location:         https://fwupd.org/downloads/6f4ed37289a5941b64b64f23330e518afd78a9ef-firmware_XPS_9360_2_4_2.cab

 max  ~  fwupdmgr update --verbose 5ffdbc0d-f340-441c-a803-8439c8c0ae10
Downloading 0.2.4.2 for XPS 13 9360 System Firmware...
(fwupdmgr:3479): Fu-DEBUG: creating path /home/max/.cache/fwupdmgr
(fwupdmgr:3479): Fu-DEBUG: skpping download as file already exists
Updating 0.2.4.2 on XPS 13 9360 System Firmware...
(fwupdmgr:3479): Fwupd-DEBUG: Emitting ::status-changed() [decompressing]
Decompressing…         [   -                                   ](fwupdmgr:3479): Fwupd-DEBUG: Emitting ::status-changed() [idle]
Decompressing…         [***************************************]
(fwupdmgr:3479): Fwupd-DEBUG: Emitting ::status-changed() [waiting-for-auth]
Authenticating…        [    \                                  ](fwupdmgr:3479): Fwupd-DEBUG: Emitting ::status-changed() [idle]
Authenticating…        [***************************************]
(fwupdmgr:3479): Fwupd-DEBUG: Emitting ::status-changed() [scheduling]
Scheduling…            [                -                      ](fwupdmgr:3479): Fwupd-DEBUG: Emitting ::status-changed() [idle]
Scheduling…            [***************************************]
(fwupdmgr:3479): Fwupd-DEBUG: Emitting ::device-changed(3f0ecc7823ee99c718693e8ecca38f54e8738dc5)
(fwupdmgr:3479): Fwupd-DEBUG: Emitting ::changed()

Comment 26 Thorsten Leemhuis 2018-01-04 11:09:12 UTC
FWIW: The problem this bug was about (EFI boot entry for fwupx64.efi not created properly) is fixed for me.

But I still can't update the BIOS on my XPS13: After running "sudo fwupdmgr update" it seems to me on the next reboort fwupx64.efi is actually started, but the update is not happening for some reasons. I can't see any failure messages. The system seems to simply reboot about five or seven seconds after starting the efi updater. 

@Peter, @Mario, @Richard: How can I debug it? is there a open bug about this issue somewhere?

Comment 27 Thorsten Leemhuis 2018-01-04 11:12:43 UTC
(In reply to Thorsten Leemhuis from comment #26)

> @Peter, @Mario, @Richard: How can I debug it? is there a open bug about this
> issue somewhere?

Follow up: What I'm seeing here is similar to what Bug 1511544 is about. That was marked as a dupe of this bug, which IMHO was a mistake, because it's a different (albeit related) issue that Jiri and I see.

Comment 28 Klaas Demter 2018-01-04 11:31:54 UTC
(In reply to Thorsten Leemhuis from comment #26)
> FWIW: The problem this bug was about (EFI boot entry for fwupx64.efi not
> created properly) is fixed for me.
> 
> But I still can't update the BIOS on my XPS13: After running "sudo fwupdmgr
> update" it seems to me on the next reboort fwupx64.efi is actually started,
> but the update is not happening for some reasons. I can't see any failure
> messages. The system seems to simply reboot about five or seven seconds
> after starting the efi updater. 
> 
> @Peter, @Mario, @Richard: How can I debug it? is there a open bug about this
> issue somewhere?

I can confirm that behaviour with bios update 0.2.4.2 on XPS 9360 and fwupd-1.0.2-1.fc27.x86_64

Greetings
Klaas

Comment 29 Mario Limonciello 2018-01-04 14:32:23 UTC
@Thorsten,

Ever since this bug has been opened UEFI FW updates have not worked in Fedora.  The root cause when it was opened has changed (the fix pjones applied fixed one problem but caused another - net cause this bug still exists).  That's why bug 1511544 is a duplicate.

In terms of what can be done, how to debug it:
1) fwupdate will turn on debugging output in the presence of the SHIM_DEBUG EFI variable (same as shim IIRC).

2) Something else that may be useful is to do a bisect to identify which commit was causing it from master.  There's only about 13 commits to fwupdate.c since version 9 was tagged.

While bisecting I would recommend unplugging the power adapter after staging with fwupd/libfwup but before the reboot.  When "successful" the firmware will show an error that you need a power adapter plugged in and reboot (it won't apply the update) allowing an easier bisection.

pjones might also be aware of what the root cause is, but he's probably been busy with other stuff since he's MIA on fwupdate stuff for a while (see how many open PR and untouched issues on Github)

Comment 30 Fernando 2018-01-04 14:54:50 UTC
(In reply to Klaas Demter from comment #28)
> (In reply to Thorsten Leemhuis from comment #26)
> > FWIW: The problem this bug was about (EFI boot entry for fwupx64.efi not
> > created properly) is fixed for me.
> > 
> > But I still can't update the BIOS on my XPS13: After running "sudo fwupdmgr
> > update" it seems to me on the next reboort fwupx64.efi is actually started,
> > but the update is not happening for some reasons. I can't see any failure
> > messages. The system seems to simply reboot about five or seven seconds
> > after starting the efi updater. 
> > 
> > @Peter, @Mario, @Richard: How can I debug it? is there a open bug about this
> > issue somewhere?
> 
> I can confirm that behaviour with bios update 0.2.4.2 on XPS 9360 and
> fwupd-1.0.2-1.fc27.x86_64
> 
> Greetings
> Klaas

Also with 0.2.5.0.

Comment 31 Mario Limonciello 2018-01-04 16:12:36 UTC
> Also with 0.2.5.0.
It's not bound by Dell firmware version, model or fwupd version.

It's strictly caused by fwupdate. (specifically fwupx64.efi).

Comment 32 Mario Limonciello 2018-01-05 23:40:05 UTC
Hi Everyone,

I've bisected master and found the problem.  I've got a PR opened here for pjones to accept:
https://github.com/rhboot/fwupdate/pull/91

I don't have any experience in generating copr builds.  Until pjones can get around to this, can someone please help generate a binary build with that patch in place?

Thanks!

Comment 33 Andrew Gunnerson 2018-01-05 23:43:48 UTC
Sure, I can make of fwupdate with that patch included in Copr. It won't be signed with Fedora's key though, so it'll need to be signed manually or secure boot needs to be disabled.

Comment 34 Andrew Gunnerson 2018-01-05 23:45:18 UTC
-- Sorry for the duplicate message; fixed a typo --

Sure, I can make a build of fwupdate with that patch included in Copr. It won't be signed with Fedora's key though, so it'll need to be signed manually or secure boot needs to be disabled.

Comment 35 Andrew Gunnerson 2018-01-06 00:05:46 UTC
Hi Mario,

Are you sure that's the same issue as in Fedora? Version '10-0.2.fc27.x86_64' from Fedora is built from commit 9669ab00e23fbc2b9d77f538e797e5aef4a0138e, which seems to compare the GUIDs properly: https://github.com/rhboot/fwupdate/blob/9669ab00e23fbc2b9d77f538e797e5aef4a0138e/efi/fwupdate.c#L1035-L1036

The commit you found that introduced the issue (6f63cdd9eabf533fce909f40bf197c699b20d363) was made after the latest version of the Fedora package.

Comment 36 Mario Limonciello 2018-01-06 00:32:21 UTC
Interesting. I wonder if it's because https://github.com/rhboot/fwupdate/commit/75391bc4c3dcfc384ae9527d3fd82933280a2276 is missing (that's definitely wrong behavior previously).


Could you instead do copr build with master plus that patch then?

Comment 37 Andrew Gunnerson 2018-01-06 01:03:58 UTC
Done! https://copr.fedorainfracloud.org/coprs/chenxiaolong/rhbz1506609-fix/

It's built from master (commit 91351b8e93da608da31a812b876aa25b394ae665) and includes PR#91.

Comment 38 Andrew Gunnerson 2018-01-06 01:05:28 UTC
By the way, the package in the Copr repo is versioned so that when Fedora releases the next update to fwupdate, it'll switch back to the official package.

Comment 39 cobratbq 2018-01-07 14:19:25 UTC
I confirm that patch above fixes the problem, for me.

I had a similar problem also on an XPS 13. I had this problem for the 0.2.4.2 firmware update and ended up installing it manually after retrieving the package via 'fwupdmgr get-updates' (used reference to download URL).

Now with 0.2.5.0 firmware available, I have looked into debugging this issue. I have installed the copr build prepared in https://bugzilla.redhat.com/show_bug.cgi?id=1506609#c37, by recommendation of Mario in github issue https://github.com/hughsie/fwupd/issues/356#issuecomment-355780214.

I can confirm that this build fixes my issue, and does indeed start the upgrade process. Previously, everything would go according to plan, but the firmware update software never started and instead normal boot process would continue. With this fix in place, the update software starts and a successful firmware update is performed. (Also considered successful if you query via 'fwupdmgr' afterwards.) The update process again looks the same as when I did an earlier firmware update (0.2.2.1 or something like that, presumably before the changes to the firmware update software.)

Comment 40 Thorsten Leemhuis 2018-01-07 14:33:31 UTC
(In reply to cobratbq from comment #39)
> I confirm that patch above fixes the problem, for me.

@hughsie: Do you have commit access to rpms/fwupdate in Fedora and could prepare a update? Should we make it easier for you to submit a pull request? @Andrew: could you prepare one? or did you do that already?

Comment 41 Andrew Gunnerson 2018-01-08 00:12:17 UTC
I just submitted a PR for the Fedora package: https://src.fedoraproject.org/rpms/fwupdate/pull-request/1

Comment 42 Fedora Update System 2018-01-08 22:46:40 UTC
fwupdate-10-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-daf33a1408

Comment 43 Fedora Update System 2018-01-09 17:43:31 UTC
fwupdate-10-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-daf33a1408

Comment 44 Max Whittingham 2018-01-10 02:57:08 UTC
After updating fwupdate, it does appear that the bios updates were able to be successfully applied.

Comment 45 Kamil Grzebien 2018-01-10 09:23:11 UTC
I can confirm that fix works on XPS 15 9560. Firmware has been successfully updated.

Comment 46 Andrey Ilyukhin 2018-01-10 12:06:54 UTC
works with XPS 15 9550 too.

Comment 47 Fedora Update System 2018-01-12 01:51:59 UTC
fwupdate-10-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.