Bug 1506629 - No alerts on Hosts site
Summary: No alerts on Hosts site
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-ui
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: gowtham
QA Contact: Martin Kudlej
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-26 13:15 UTC by Filip Balák
Modified: 2017-12-18 04:39 UTC (History)
3 users (show)

Fixed In Version: tendrl-ui-1.5.4-1.el7rhgs.noarch.rpm
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:39:14 UTC
Target Upstream Version:


Attachments (Terms of Use)
Alerts page (36.90 KB, image/png)
2017-10-26 13:15 UTC, Filip Balák
no flags Details
Hosts page (85.85 KB, image/png)
2017-10-26 13:16 UTC, Filip Balák
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC
Github https://github.com/Tendrl ui issues 719 None None None 2017-11-07 08:08:13 UTC

Description Filip Balák 2017-10-26 13:15:33 UTC
Created attachment 1343728 [details]
Alerts page

Description of problem:
I have one node down. In Alerts website is alert that confirms it but in Hosts site is no alert (No data) displayed in alerts column.

Version-Release number of selected component (if applicable):
tendrl-ansible-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.3-1.el7rhgs.noarch
tendrl-api-1.5.3-2.el7rhgs.noarch
tendrl-notifier-1.5.3-1.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-node-agent-1.5.3-3.el7rhgs.noarch
tendrl-ui-1.5.3-2.el7rhgs.noarch
tendrl-grafana-plugins-1.5.3-2.el7rhgs.noarch
tendrl-monitoring-integration-1.5.3-2.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-api-httpd-1.5.3-2.el7rhgs.noarch
glusterfs-3.8.4-48.el7rhgs.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Import cluster with hosts.
2. Shut down 1 host.
3. Check alerts on Alerts page.
4. Check column with alerts on Hosts page.

Actual results:
On Alerts page is displayed 1 alert suggesting that the host is down. On Hosts page is no mention about this alert.

Expected results:
There should be number of alerts with link. (https://redhat.invisionapp.com/share/8QCOEVEY9#/screens/244738623)

Additional info:

Comment 1 Filip Balák 2017-10-26 13:16:59 UTC
Created attachment 1343729 [details]
Hosts page

Comment 2 gowtham 2017-11-07 08:27:45 UTC
This issue is fixed, please verify

Comment 4 Filip Balák 2017-11-14 08:59:55 UTC
Seems ok -> VERIFIED
Tested with:
tendrl-node-agent-1.5.4-2.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.4-2.el7rhgs.noarch
tendrl-api-1.5.4-2.el7rhgs.noarch
tendrl-api-httpd-1.5.4-2.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-3.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-notifier-1.5.4-2.el7rhgs.noarch
tendrl-ansible-1.5.4-1.el7rhgs.noarch
tendrl-ui-1.5.4-2.el7rhgs.noarch
tendrl-grafana-plugins-1.5.4-3.el7rhgs.noarch

Comment 7 errata-xmlrpc 2017-12-18 04:39:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.