Bug 150666 - Timeout error when the daemon starts. Tried to figure out but failed to do so
Timeout error when the daemon starts. Tried to figure out but failed to do so
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: mysql (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-03-09 09:18 EST by sendilnath
Modified: 2013-07-02 23:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-28 17:54:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description sendilnath 2005-03-09 09:18:59 EST
Description of problem:
Timeout when starting the mysql daemon

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Suzanne Hillman 2005-03-11 15:27:10 EST
Type of machine? Does it happen on more than one machine? What is the precise
error it gives you, and after how much time? Anything showing up in logs?
Comment 2 August Zajonc 2005-03-19 02:04:16 EST
Two steps to a resolution:

Check if 
/usr/bin/mysqladmin -uUNKNOWN_MYSQL_USER ping

runs from the command line while mysql is running. 

If it does not, add an anonymous user with no permissions to your server, change
the UNKNOWN_MYSQL_USER to portion of the command to match your new user, and try
running it again. 

/usr/bin/mysqladmin -u anonymous ping

Your results would look something like this:

/usr/bin/mysqladmin -uUNKNOWN_MYSQL_USER ping
/usr/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'UNKNOWN_MYSQL_US'@'localhost' 

/usr/bin/mysqladmin -u anonymous ping
mysqld is alive

If you've gotten to this point, update /etc/init.d/mysqld and change the line 41
to your new command. 

OK, now scroll down, and change line 79 in the restart section from 
sleep 2 to 
sleep 5

These two changes should solve things for you. Please post a note if they do. 

The proper error text for others searching is:
Timeout error occurred trying to start MySQL Daemon.

Hopefully they try searching in the comments. Your report is a touch light on
details. The more details you include the more likely others will find your bug
if they have a similar one or be able to help you if they solved it. 
Comment 3 Michael Hampton 2005-03-20 17:09:37 EST
I am seeing the same timeout error with mysql-server-4.1.7-4.RHEL4.1.i386.
Changing the timeout will not help, as the server doesn't start up:

The following is from /var/log/mysqld.log

050320 15:45:29  mysqld started
050320 15:45:29 [ERROR] bdb:  unable to initialize mutex: Function not implemented
050320 15:45:29 [ERROR] bdb:  process-private: unable to initialize environment
lock: Function not implemented
050320 15:45:30  InnoDB: Started; log sequence number 0 43634
050320 15:45:30 [ERROR] Can't init databases
050320 15:45:30 [ERROR] Aborting

050320 15:45:30  InnoDB: Starting shutdown...
050320 15:45:33  InnoDB: Shutdown completed; log sequence number 0 43634
050320 15:45:33 [Note] /usr/libexec/mysqld: Shutdown complete

050320 15:45:33  mysqld ended
Comment 4 August Zajonc 2005-03-21 01:09:49 EST

Yours is a different issue. In this one mysql starts but the ping fails, and the
timeout is too short. 

What is your enviroment? Are you running on redhat binaries? I'd recommend
posting a new bug (if not a dup) and including more information on your
enviroment if you are, including any issues around forcing updates etc. 

You might also consider skip-bdb in /etc/my.conf [mysqld] as a short term fix. 

Please do specify more of your enviroment however, you will find folks who are
more familiar with all the various factors that can create a bug reluctant to
help unless they can narrow the range of possabilities somewhat. 
Comment 5 Tom Lane 2005-03-21 02:02:02 EST
I doubt that "timeout too short" is the issue.  Either the mysql daemon is failing to start at all (as 
Michael suggests) or the daemon is fine but the method the init script uses to check whether the 
daemon is alive is wrong.  There is a known problem with the latter bit --- see bug #142328 for
instance --- but I believe this is fixed in mysql-4.1.7-5.RHEL4.1 and up.  The initial report in this 
thread is so content-free that I can't tell whether that's the issue or not.

I'm interested in Michael's comment though.  That seems to indicate a pthread failure, which would not 
be mysql's fault in particular, but it would suggest a glibc problem.  I've not seen it in my own testing 
though.  Michael, what glibc package do you have exactly?
Comment 6 Tom Lane 2008-04-28 17:54:51 EDT
Closing this bug for lack of sufficient information to investigate the problem (or problems?)  If you still see 
it with current RHEL4 packages, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.