Bug 150668 - Swap is not enabled
Summary: Swap is not enabled
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-09 14:32 UTC by Alfred Glanzer
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-04 13:17:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
As requested : fstab (789 bytes, text/plain)
2005-03-09 18:01 UTC, Alfred Glanzer
no flags Details

Description Alfred Glanzer 2005-03-09 14:32:38 UTC
Description of problem:
Swap-space on separate partition is not working. I am not sure if this
is related to initscripts or that the naming of the swap-space in
fstab is causing this.

Manually enabling swap with swapon /dev/hd?? is working without any
problems. The command swapon -a -e does nothing !!!

Version-Release number of selected component (if applicable):
initscripts-8.05-1

Additional info:

These problems are on a clean FC4 install (through http) with a FC3
boot-disk (the FC4 boot disk does not work).

Comment 1 Bill Nottingham 2005-03-09 17:18:02 UTC
Please attach your /etc/fstab.

Comment 2 Alfred Glanzer 2005-03-09 18:01:02 UTC
Created attachment 111817 [details]
As requested : fstab

This fstab is not touched at all: original from install !

Comment 3 Bill Nottingham 2005-03-09 18:13:30 UTC
Does:

swapon -L SWAP-hda2

work?

Comment 4 Alfred Glanzer 2005-03-09 21:30:04 UTC
server /etc> swapon -L SWAP-hda2
swapon: cannot find the device for SWAP-hda2
server /etc> 

Sorry, it does not (yet) work !

Comment 5 Elliot Lee 2005-03-09 22:36:07 UTC
Have you run mkswap since the install?

Comment 6 Alfred Glanzer 2005-03-10 09:45:40 UTC
Yes, I did run mkswap, but on a file, because I needed some swap-space.

The disk-swap-space on my system can easily be enabled by swapon
/dev/hda2 ! I did not run mkswap on hda2.

ps: it would be very nice if, during setup, a swap-file can be choosen
as swap, and not only a separate partition !!

Comment 7 Karel Zak 2005-03-18 13:00:48 UTC
You have in /etc/fstab as device identicication "LABEL=SWAP-hda2". It means the
'swapon' does exactly same work as:

     swapon -L SWAP-hda2

The conversion from LABEL to path to device (=/dev/hda2) is possible only if
there is label in swap header block. You have to run:

     mkswap -L SWAP-hda2 /dev/hda2

before "swapon -a" or "swapon -L SWAP-hda2".




Note You need to log in before you can comment on or make changes to this bug.