Bug 1506809 - ICE when compiling matplotlib
Summary: ICE when compiling matplotlib
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-26 19:57 UTC by Ben Boeckel
Modified: 2018-02-06 15:32 UTC (History)
8 users (show)

Fixed In Version: gcc-7.3.1-2.fc26 gcc-7.3.1-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-06 10:50:59 UTC


Attachments (Terms of Use)
Log output by GCC (1.38 MB, text/x-csrc)
2017-10-26 19:58 UTC, Ben Boeckel
no flags Details
Fixed GCC log file (1.38 MB, text/x-csrc)
2017-12-07 19:38 UTC, Ben Boeckel
no flags Details


Links
System ID Priority Status Summary Last Updated
GNU Compiler Collection 82264 None None None 2017-12-07 20:20:50 UTC

Description Ben Boeckel 2017-10-26 19:57:12 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ben Boeckel 2017-10-26 19:58:15 UTC
Oops, hit enter too soon, sorry.

Description of problem:
ICE when compiling matplotlib's png module.

Version-Release number of selected component (if applicable):
gcc-7.2.1-2.fc26.x86_64

Comment 2 Ben Boeckel 2017-10-26 19:58:44 UTC
Created attachment 1343960 [details]
Log output by GCC

Comment 3 Marek Polacek 2017-12-07 12:19:28 UTC
The log file you've provided looks weird to me and it doesn't demonstrate the ICE; I get:

error: stray ‘#’ in program
error: stray ‘\’ in program

and similar.  Can you provide the preprocessed file stored in /tmp/cc*.out?

Comment 4 Ben Boeckel 2017-12-07 19:38:11 UTC
Created attachment 1364449 [details]
Fixed GCC log file

That was the .out file mentioned in the header comment. It looks like GCC dumped error/warning output in the middle of the code. I'm uploading a fixed version.

Comment 5 Marek Polacek 2017-12-07 20:20:51 UTC
Thanks.

This is https://gcc.gnu.org/bugzilla/show_bug.cgi?id=82264 which has been fixed on trunk and in gcc-7, so it will be fixed in the next Fedora gcc release (before Christmas).

Comment 6 Fedora Update System 2018-01-31 07:49:45 UTC
gcc-7.3.1-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-75d88970d0

Comment 7 Fedora Update System 2018-01-31 07:56:14 UTC
gcc-7.3.1-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-aa879be08e

Comment 8 Fedora Update System 2018-01-31 18:43:25 UTC
gcc-7.3.1-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-aa879be08e

Comment 9 Fedora Update System 2018-01-31 22:46:18 UTC
gcc-7.3.1-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-75d88970d0

Comment 10 Fedora Update System 2018-02-06 10:50:59 UTC
gcc-7.3.1-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2018-02-06 15:32:25 UTC
gcc-7.3.1-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.