Bug 1506845 - Bind plugin produces wrong timestamp - upstream bug
Summary: Bind plugin produces wrong timestamp - upstream bug
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: collectd
Version: el6
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Ruben Kerkhof
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-27 00:56 UTC by Dave McDonnell
Modified: 2018-04-19 16:04 UTC (History)
6 users (show)

Fixed In Version: collectd-4.10.9-5.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-19 16:04:21 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github collectd collectd issues 1268 None None None 2017-10-27 00:59:05 UTC

Description Dave McDonnell 2017-10-27 00:56:16 UTC
Description of problem:
Bind plugin produces incorrect timestamps in collectd due to bind generating UTC timestamps which are incorrectly interpreted in the local timezone.

This has been fixed upstream in later versions of collectd.

Patch - https://github.com/collectd/collectd/commit/23963a8b9fae668376dd55917afbb38d759dd1d0

(There is an additional larger commit that expands the fix to freebsd, as the commit above doesnt compile on freebsd)

Version-Release number of selected component (if applicable):
collectd-4.10.9-4.el6

How reproducible:
Consistently

Steps to Reproduce:
1. Enable bind plugin with timezone other than UTC
2. Verify data collected has wrong times

Actual results:
Timezone is incorrect on collected data

Expected results:
Timezone should be correct

Additional info:
This might apply EPEL7 as well, I think the fix is in collectd 5.6 codebase.

Comment 1 Fedora Update System 2018-04-04 14:42:00 UTC
collectd-4.10.9-5.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-2a7eb3d385

Comment 2 Fedora Update System 2018-04-04 17:46:01 UTC
collectd-4.10.9-5.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-2a7eb3d385

Comment 3 Fedora Update System 2018-04-19 16:04:21 UTC
collectd-4.10.9-5.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.