Bug 1506888 - Fedora scientific build: emacs installation doesn't work
Fedora scientific build: emacs installation doesn't work
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Václav Pavlín
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-10-27 01:40 EDT by Amit Saha
Modified: 2018-01-23 17:08 EST (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-23 17:08:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Saha 2017-10-27 01:40:49 EDT
Description of problem:

When trying to build the Fedora Scientific 27 ISO (https://pagure.io/fork/amitksaha/fedora-kickstarts/blob/f27/f/fedora-live-scientific_kde.ks), I get:

Problem 1: conflicting requests
  - nothing provides libm17n-core.so.0()(64bit) needed by emacs-1:25.3-3.fc27.x86_64



Version-Release number of selected component (if applicable):

emacs-1:25.3-3.fc27.x86_64


How reproducible:

Always


Steps to Reproduce:

$ sudo livecd-creator --verbose --config=fedora-live-scientific_kde.ks --fslabel=Fedora-LiveCD --cache=/var/cache/live


Actual results:

Nothing provides libm17n-core.so.0()(64bit) needed by emacs-1:25.3-3.fc26.x86_64


Expected results:

emacs installation succeeds


Additional info:
Comment 1 Jan Synacek 2017-10-30 02:00:21 EDT
(In reply to Amit Saha from comment #0)
> Description of problem:
> 
> When trying to build the Fedora Scientific 27 ISO
> (https://pagure.io/fork/amitksaha/fedora-kickstarts/blob/f27/f/fedora-live-
> scientific_kde.ks), I get:
> 
> Problem 1: conflicting requests
>   - nothing provides libm17n-core.so.0()(64bit) needed by
> emacs-1:25.3-3.fc27.x86_64

That means that the library is not present on the system. It seems to be coming from the package 'm17n-lib'. Emacs has 'BuildRequires: m17n-lib-devel' in the spec file. I doubt that this is an Emacs problem. It looks like the dependencies were not correctly installed, which can possibly be a bug in dnf or it the livecd-creator. Or maybe the system was altered by other means.
Comment 2 Neal Gompa 2017-10-30 09:48:21 EDT
This is not livecd-tools. This is the fedora-kde-common kickstart excluding all input methods.

See: https://pagure.io/fedora-kickstarts/blob/master/f/fedora-kde-common.ks#_60
Comment 3 Amit Saha 2017-10-31 00:44:28 EDT
(In reply to Neal Gompa from comment #2)
> This is not livecd-tools. This is the fedora-kde-common kickstart excluding
> all input methods.
> 
> See:
> https://pagure.io/fedora-kickstarts/blob/master/f/fedora-kde-common.ks#_60

:-(
Comment 4 Rex Dieter 2017-10-31 09:11:50 EDT
This may be a change in behavior of the live compose tools... I seem to recall that excluded items would still get pulled into the compose when/if anything explicitly depended on them.

If that's no longer the case, we (kde-sig) ought to revisit the decision to omit that stuff.
Comment 5 Amit Saha 2017-10-31 22:35:34 EDT
Is there a way to override this in the fedora scientific kickstart? Or can I do something to help fix this?
Comment 6 Rex Dieter 2017-11-03 13:26:53 EDT
https://pagure.io/fedora-kickstarts/pull-request/309

I didn't see that referenced here yet
Comment 7 Kevin Kofler 2017-11-03 14:12:27 EDT
(In reply to Rex Dieter from comment #4)
> This may be a change in behavior of the live compose tools... I seem to
> recall that excluded items would still get pulled into the compose when/if
> anything explicitly depended on them.

This was deliberately changed because it was the only way to reliably exclude weak dependencies:
https://github.com/livecd-tools/livecd-tools/commit/617e737474fb17da0e266422367e56ec54516bec

(Note that the OP is using livecd-creator, not livemedia-creator. AFAICT, this was not changed in Anaconda, which is what is used by livemedia-creator.)

I find the new livecd-creator behavior very handy for Kannolo.
Comment 8 Neal Gompa 2017-11-03 14:19:54 EDT
(In reply to Kevin Kofler from comment #7)
> (In reply to Rex Dieter from comment #4)
> > This may be a change in behavior of the live compose tools... I seem to
> > recall that excluded items would still get pulled into the compose when/if
> > anything explicitly depended on them.
> 
> This was deliberately changed because it was the only way to reliably
> exclude weak dependencies:
> https://github.com/livecd-tools/livecd-tools/commit/
> 617e737474fb17da0e266422367e56ec54516bec
> 
> (Note that the OP is using livecd-creator, not livemedia-creator. AFAICT,
> this was not changed in Anaconda, which is what is used by
> livemedia-creator.)
> 
> I find the new livecd-creator behavior very handy for Kannolo.

This behavior is slated to go into Anaconda too, I just have to rework it a bit for the feedback I got from the developers.
Comment 9 Kevin Kofler 2017-11-03 14:29:26 EDT
I think the right solution to get rid of the error would be to bring the optional -minimization.ks back:
https://lists.fedoraproject.org/archives/list/kde@lists.fedoraproject.org/message/Q6R4QEKRHVXTVKOW7KWEYDZ2YS3XTXQV/
Comment 10 Rex Dieter 2017-11-03 14:38:16 EDT
Long term possibly, short-term we need minimalistic fixes (or workarounds)
Comment 11 Kevin Kofler 2017-11-03 14:58:02 EDT
This is the minimalistic fix, it does not change the contents of the KDE Spin at all unlike your approach, it only fixes the Scientific Spin.
Comment 12 Amit Saha 2017-11-03 20:01:16 EDT
(In reply to Kevin Kofler from comment #9)
> I think the right solution to get rid of the error would be to bring the
> optional -minimization.ks back:
> https://lists.fedoraproject.org/archives/list/kde@lists.fedoraproject.org/
> message/Q6R4QEKRHVXTVKOW7KWEYDZ2YS3XTXQV/

+1. 

Thanks all for this.
Comment 13 Amit Saha 2017-12-28 19:55:32 EST
(In reply to Rex Dieter from comment #10)
> Long term possibly, short-term we need minimalistic fixes (or workarounds)

This is still an issue. Would you please be able to take a look when you get a chance?
Comment 14 Amit Saha 2017-12-28 22:17:44 EST
(In reply to Amit Saha from comment #13)
> (In reply to Rex Dieter from comment #10)
> > Long term possibly, short-term we need minimalistic fixes (or workarounds)
> 
> This is still an issue. Would you please be able to take a look when you get
> a chance?

Alternatively, i have added the workaround to the scientific spin instead: https://pagure.io/fedora-kickstarts/pull-request/321

Could you please merge it?
Comment 15 Kevin Kofler 2017-12-29 00:10:43 EST
Well, that will select ALL m17n* packages, not just those that would have been selected by default.
Comment 16 Amit Saha 2017-12-29 03:15:22 EST
(In reply to Kevin Kofler from comment #15)
> Well, that will select ALL m17n* packages, not just those that would have
> been selected by default.

That's OK for a workaround right? Alternatively, if you could suggest a way to find(In reply to Kevin Kofler from comment #7)
> (In reply to Rex Dieter from comment #4)
> > This may be a change in behavior of the live compose tools... I seem to
> > recall that excluded items would still get pulled into the compose when/if
> > anything explicitly depended on them.
> 
> This was deliberately changed because it was the only way to reliably
> exclude weak dependencies:
> https://github.com/livecd-tools/livecd-tools/commit/
> 617e737474fb17da0e266422367e56ec54516bec
> 
> (Note that the OP is using livecd-creator, not livemedia-creator. AFAICT,
> this was not changed in Anaconda, which is what is used by
> livemedia-creator.)

Hence, the rawhide
Comment 17 Amit Saha 2017-12-29 03:19:45 EST
(In reply to Amit Saha from comment #16)
> (In reply to Kevin Kofler from comment #15)
> > Well, that will select ALL m17n* packages, not just those that would have
> > been selected by default.
> 
> That's OK for a workaround right? Alternatively, if you could suggest a way
> to find(In reply to Kevin Kofler from comment #7)
> > (In reply to Rex Dieter from comment #4)
> > > This may be a change in behavior of the live compose tools... I seem to
> > > recall that excluded items would still get pulled into the compose when/if
> > > anything explicitly depended on them.
> > 
> > This was deliberately changed because it was the only way to reliably
> > exclude weak dependencies:
> > https://github.com/livecd-tools/livecd-tools/commit/
> > 617e737474fb17da0e266422367e56ec54516bec
> > 
> > (Note that the OP is using livecd-creator, not livemedia-creator. AFAICT,
> > this was not changed in Anaconda, which is what is used by
> > livemedia-creator.)
> 
> Hence, the rawhide

Sorry. The rawhide builds are passing for the last two weeks. I am not sure what changed between f27 and rawhide since there were no changes to the scientific kickstart. If `livemedia-creator` behavior was pulling in m17n-lib-devel package required by emacs, it shouldn't have been a problem on F27 as well.
Comment 18 Amit Saha 2017-12-29 05:35:03 EST
(In reply to Amit Saha from comment #14)
> (In reply to Amit Saha from comment #13)
> > (In reply to Rex Dieter from comment #10)
> > > Long term possibly, short-term we need minimalistic fixes (or workarounds)
> > 
> > This is still an issue. Would you please be able to take a look when you get
> > a chance?
> 
> Alternatively, i have added the workaround to the scientific spin instead:
> https://pagure.io/fedora-kickstarts/pull-request/321

Cancelled this PR. I am going to switch to livemedia-creator for my testing.

However, what is the long-term fix once we make livemedia-creator behavior same as livecd-creator?
Comment 19 Amit Saha 2017-12-29 05:38:39 EST
(In reply to Amit Saha from comment #18)
> (In reply to Amit Saha from comment #14)
> > (In reply to Amit Saha from comment #13)
> > > (In reply to Rex Dieter from comment #10)
> > > > Long term possibly, short-term we need minimalistic fixes (or workarounds)
> > > 
> > > This is still an issue. Would you please be able to take a look when you get
> > > a chance?
> > 
> > Alternatively, i have added the workaround to the scientific spin instead:
> > https://pagure.io/fedora-kickstarts/pull-request/321
> 
> Cancelled this PR. I am going to switch to livemedia-creator for my testing.
> 
> However, what is the long-term fix once we make livemedia-creator behavior
> same as livecd-creator?

And that would be: https://bugzilla.redhat.com/show_bug.cgi?id=1506888#c9 I think?
Comment 20 Kevin Kofler 2017-12-29 07:45:51 EST
Yes. As I wrote there, the minimization really needs to be separate from the kde-base kickstart.
Comment 21 Amit Saha 2018-01-07 18:39:04 EST
Looks like this is happening again: https://kojipkgs.fedoraproject.org//work/tasks/6315/24056315/livemedia-out.log which is weried, since the livemedia-creator version hasn't changed since the last successful build.
Comment 22 Kevin Kofler 2018-01-08 04:49:31 EST
When using livemedia-creator, this logic is in Anaconda, not in livemedia-creator itself.
Comment 23 Amit Saha 2018-01-08 04:52:58 EST
(In reply to Kevin Kofler from comment #22)
> When using livemedia-creator, this logic is in Anaconda, not in
> livemedia-creator itself.

Ah, so perhaps https://bugzilla.redhat.com/show_bug.cgi?id=1506888#c8 - this change has been made in anaconda as well?
Comment 24 Amit Saha 2018-01-16 16:58:43 EST
(In reply to Kevin Kofler from comment #20)
> Yes. As I wrote there, the minimization really needs to be separate from the
> kde-base kickstart.

I created a PR for this: https://pagure.io/fedora-kickstarts/pull-request/326

Please take a look.
Comment 25 Dennis Gilmore 2018-01-18 09:14:34 EST
fedora kickstarts are tested with and work using livemedia-creator I would rather see you use the same supported tools used to compose Fedora. given that anaconda however deals with things just fine I would say that livecd-creator is doing something wrong here.
Comment 26 Kevin Kofler 2018-01-18 09:40:13 EST
According to comment #21, this now also happens with livemedia-creator.
Comment 27 Amit Saha 2018-01-18 15:43:33 EST
(In reply to Dennis Gilmore from comment #25)
> fedora kickstarts are tested with and work using livemedia-creator I would
> rather see you use the same supported tools used to compose Fedora. given
> that anaconda however deals with things just fine I would say that
> livecd-creator is doing something wrong here.

Indeed, this is still an issue: https://koji.fedoraproject.org/koji/taskinfo?taskID=24271728

In addition, https://pagure.io/fedora-kickstarts/pull-request/326 is probably a fair change as well (additional context: https://lists.fedoraproject.org/archives/list/kde@lists.fedoraproject.org/message/Q6R4QEKRHVXTVKOW7KWEYDZ2YS3XTXQV/)
Comment 28 Amit Saha 2018-01-23 17:08:57 EST
https://pagure.io/fedora-kickstarts/pull-request/326 has been pushed and that has fixed the Fedora Scientific builds.

Note You need to log in before you can comment on or make changes to this bug.