Bug 1506894 - The default repo for modular server netinst is invalid
Summary: The default repo for modular server netinst is invalid
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-modular-release
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen Gallagher
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException AcceptedBlocker
Depends On:
Blocks: F27FinalFreezeException 1492240 F27ServerBetaBlocker
TreeView+ depends on / blocked
 
Reported: 2017-10-27 06:01 UTC by lnie
Modified: 2017-11-08 22:10 UTC (History)
4 users (show)

Fixed In Version: Fedora-Modular-27-20171029.n.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-08 22:10:23 UTC


Attachments (Terms of Use)
screenshot (122.34 KB, image/png)
2017-10-27 06:01 UTC, lnie
no flags Details
anaconda.log (11.60 KB, text/plain)
2017-10-27 06:02 UTC, lnie
no flags Details
packaging.log (2.38 KB, text/plain)
2017-10-27 06:02 UTC, lnie
no flags Details

Description lnie 2017-10-27 06:01:50 UTC
Created attachment 1344174 [details]
screenshot

Description of problem:
As shown in the attached screenshot,
anaconda keeps saying: error setting up base repository.

Version-Release number of selected component (if applicable):
Fedora-Modular-Server-netinst-x86_64-27-20171026.n.3.iso

How reproducible:
always 

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2017-10-27 06:02:17 UTC
Created attachment 1344175 [details]
anaconda.log

Comment 2 lnie 2017-10-27 06:02:42 UTC
Created attachment 1344176 [details]
packaging.log

Comment 3 Stephen Gallagher 2017-10-27 11:49:06 UTC
Yeah, there's something wrong with the repositories that are being injected into the Anaconda process. This must be fixed.

Comment 4 Jiri Konecny 2017-10-27 18:21:24 UTC
PR: https://github.com/rhinstaller/anaconda/pull/1227

Comment 5 Stephen Gallagher 2017-10-30 01:38:30 UTC
Resolved in compose Fedora-Modular-27-20171029.n.0/

Comment 6 Fedora Update System 2017-10-30 16:02:40 UTC
anaconda-27.20.4-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-501b8f778f

Comment 7 Stephen Gallagher 2017-10-30 16:03:24 UTC
Reopening to be considered for blocker status for F27

Comment 8 Fedora Blocker Bugs Application 2017-10-30 16:04:52 UTC
Proposed as a Blocker for 27-server-beta by Fedora user sgallagh using the blocker tracking app because:

 "When using a release-blocking dedicated installer image, the installer must be able to use either HTTP or FTP repositories (or both) as package sources. Release-blocking network install images must default to a valid publicly-accessible package source."

Comment 9 Geoffrey Marr 2017-10-30 20:31:46 UTC
Discussed during the 2017-10-30 blocker review meeting: [1]

The decision to classify this bug as an AcceptedBlocker and an AcceptedFreezeException was made as it's necessary to update anaconda to have this work consistently between the regular and Server modular releases; this is accepted as a Final freeze exception to indicate that we want the change in Final to allow the two to be consistent. accepted as a Server Beta blocker as this must be addressed somehow for the Server Beta release.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-10-30/f27-blocker-review.2017-10-30-16.00.txt

Comment 10 Fedora Update System 2017-10-31 19:09:28 UTC
anaconda-27.20.4-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-501b8f778f

Comment 11 Fedora Update System 2017-11-02 20:50:50 UTC
anaconda-27.20.4-4.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-501b8f778f

Comment 12 Fedora Update System 2017-11-04 18:01:20 UTC
anaconda-27.20.4-4.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-501b8f778f

Comment 13 Fedora Update System 2017-11-08 22:10:23 UTC
anaconda-27.20.4-4.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.