Bug 1506937 - Save vmcore failure on 4.14.* kernel: vtop4_x86_64: Can't get the symbol of init_level4_pgt.
Summary: Save vmcore failure on 4.14.* kernel: vtop4_x86_64: Can't get the symbol of i...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools   
(Show other bugs)
Version: 7.5-Alt
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Baoquan He
QA Contact: Qiao Zhao
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-27 08:42 UTC by Qiao Zhao
Modified: 2018-04-10 14:13 UTC (History)
4 users (show)

Fixed In Version: kexec-tools-2.0.15-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 14:12:27 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0807 None None None 2018-04-10 14:13 UTC

Description Qiao Zhao 2017-10-27 08:42:36 UTC
Description of problem:
Kdump kernel save vmcore failure on 4.14.* kernel. Here is some console log by test machine:

] Reached target Initrd Default Target. 
         Starting dracut pre-pivot and cleanup hook... 
[    
  OK     
] Started dracut pre-pivot and cleanup hook. 
         Starting Kdump Vmcore Save Service... 
kdump: dump target is /dev/mapper/rhel_ibm--x3950x6--01-root 
kdump: saving to /sysroot//var/crash/127.0.0.1-2017-10-26-23:52:33/ 
kdump: saving vmcore-dmesg.txt 
kdump: saving vmcore-dmesg.txt complete 
kdump: saving vmcore 
sadump: does not have partition header 
sadump: read dump device as unknown format 
sadump: unknown format 
LOAD (0) 
  phys_start : 1000000 
  phys_end   : 2388000 
  virt_start : ffffffff81000000 
  virt_end   : ffffffff82388000 

... ...
 
Buffer size for the cyclic mode: 4194304 
vtop4_x86_64: Can't get the symbol of init_level4_pgt. 
readmem: Can't convert a virtual address(ffffffff81c10284) to physical address. 
readmem: type_addr: 0, addr:ffffffff81c10284, size:390 
check_release: Can't get the address of system_utsname. 
 
makedumpfile Failed. 
kdump: saving vmcore failed 
[      
FAILED   
] Failed to start Kdump Vmcore Save Service. 
See 'systemctl status kdump-capture.service' for details. 



Version-Release number of selected component (if applicable):
kernel-4.14.0-0.rc6.1.el7a.x86_64
kexec-tools-2.0.15-1.el7.x86_64
dracut-033-502.el7.x86_64

How reproducible:


Steps to Reproduce:
1. Please set --message-level to 31 and also set rd.debug=3.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Joseph Skupniewicz 2018-01-21 08:23:16 UTC
Confirmed in Debian as well.

Linux 4.14.0-1-rt-amd64 #1 SMP PREEMPT RT Debian 4.14.2-1 (2017-11-30)
kexec-tools 2.0.15-1 amd64

Comment 8 errata-xmlrpc 2018-04-10 14:12:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0807


Note You need to log in before you can comment on or make changes to this bug.