Bug 150696 - Does this package need to be removed from Fedora Extras
Does this package need to be removed from Fedora Extras
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-09 14:21 EST by Jef Spaleta
Modified: 2013-01-09 22:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-14 11:19:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2005-03-09 14:21:33 EST
Description of problem:
looking at the spec file in cvs.
BuildRequires: gcc-c++, libdvdread-devel, libogg-devel,libvorbis-devel

libdvdread is not in extras... as a result ogmtools as currently
implemented in Extras isn't going to build cleanly.. if its ever
requested to be built. Either ogmtools needs to be pulled out or
libdvdread needs to be included

Now I've had a little discussion with some other people about whether
or not libdvdread can be included into Extras. The finer technical
points are just beyond my feeble brain's comprehension, but I'll give
you my limited understanding of the situation as was explained to me.  
libdvdread should be okay to include in Extras because libdvdread
dlopens libdvdcss. Its libdvdcss that can not be included into Extras.
The outstanding technical question becomes... what happens if
libdvdread goes to dlopen libdvdcss but can't find it? If libdvdread
and applications that use libdvdread can handle the situation when
libdvdcss isnt available then there shouldn't be any problem including
libdvdread into extras.

I'm not equiped with enough understanding to facilite a discussion on
the matter, so I'm bringing it to your attention in the hopes you can
find the best solution that works for the ogmtools package. As it
stands now ogmtools can not be built because libdvdread-devel is not
part of Extras or Core.

-jef
Comment 1 David Lawrence 2005-04-14 10:38:12 EDT
Moving to General component so as to be able to remove the ogmtools component
since deleting bugs is not an option. Please close this bug if no longer valid.
Comment 2 Matthias Saou 2005-04-14 11:19:36 EDT
OK, closing this bug with a simple "yes, it should and will be removed" to the
bug's subject.

Note You need to log in before you can comment on or make changes to this bug.