Bug 150697 - Cannot add comment
Cannot add comment
Status: CLOSED WORKSFORME
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity high (vote)
: ---
: ---
Assigned To: David Lawrence
https://bugzilla.redhat.com/beta/show...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-09 14:37 EST by Gary Lawrence Murphy
Modified: 2007-04-18 13:20 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 22:58:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Lawrence Murphy 2005-03-09 14:37:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040804

Description of problem:
attempting to add a comment, with resolution NOT changed, gives ...


Not allowed
You tried to change the Resolution field from no value to NOTABUG, but only the owner or submitter of the bug, or a sufficiently empowered user, may change that field.

Please press Back and try again.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. fill out only the comment area
2. click to submit
3.
  

Additional info:
Comment 1 David Lawrence 2005-03-11 13:12:51 EST
When you back up, is the "Leave as <something>" radio button checked?
If it is set to something else then Bugzilla thinks you are trying to
change the status. Some browsers may not set this properly when
rendering the page. Does this occur with the Beta or older version of
Bugzilla?
Comment 2 Gary Lawrence Murphy 2005-03-14 16:34:31 EST
This is all occuring with the version of bugzilla at
bugzilla.redhat.com, and it just happened again, using FireFox 1.0 and
trying to leave another comment; when I back up, yes, indeed the
select buttons are ALL unchecked, so if I check "Leave as ..." the
comment goes through.

Also, on "Leave assigned" all options were also unchecked, but leaving
those as they were did not appear to bother bugzilla and the comment
went through.

On this page, however, I see the "Leave as" button IS checked; perhaps
because I had just checked it on a previous report form?  Could be
this is a mozilla issue ...
Comment 3 Gary Lawrence Murphy 2005-03-14 16:36:08 EST
Sorry, that bugzilla address was not correct: This behaviour was
experienced on https://bugzilla.redhat.com/beta/show_bug.cgi?id=150699
Comment 4 David Lawrence 2005-03-14 16:44:02 EST
Strange, I am unable to replicate this myself. I have heard rare occasions where
certain browser versions can behave unpredictably and not selected a default
radio  checkbox properly which will cause it to submit something the user did
not intend.  I have also heard cases where text fields were left blank where
text was supposed to be. Are you coming into the bug report through normal means
such as clicking on a bug_id in a query list? Or hitting back a few times from
another page you went to after viewing the bug?
Comment 5 Gary Lawrence Murphy 2005-03-14 21:30:17 EST
I'm using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041118
Firefox/1.0 -- and I typically cut the URL for these links from the email
and paste into the location bar (I've done this now for this post) because
my default browser is the text-mode w3m (I hate design-noise ;)

I'll just click OK on this now, and see what happens ... if there's no more from
me added after this paragraph, then it worked this time ...
Comment 6 Gary Lawrence Murphy 2005-03-14 21:32:09 EST
Hmmm ... worked.  Maybe it's one for the Journal of Unreproduceable Results :(

Let me exit the browser and come back ...
Comment 7 Gary Lawrence Murphy 2005-03-14 21:35:59 EST
Both buttons are checked ... ok, let's mark this a non-issue for bugzilla until
I can reproduce it again.  Could be any of a thousand reasons, if it happens
again, I'll try to narrow it down better.

sorry for all the trouble.
Comment 8 David Lawrence 2005-03-14 22:58:45 EST
No trouble at all. I appreciate all of the help and patience. I know it has been
reported by others but is very elusive and I have never been able to explain it or  
reproduce it personally. If you do figure out anything later please let me know.

Note You need to log in before you can comment on or make changes to this bug.