Bug 1506970 - subscription-manager-cockpit : Change the default url in cockpit to subscription.rhsm.redhat.com from subscription.rhn.redhat.com
Summary: subscription-manager-cockpit : Change the default url in cockpit to subscript...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: Red Hat subscription-manager QE Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-27 09:54 UTC by Shwetha Kallesh
Modified: 2018-04-10 09:52 UTC (History)
6 users (show)

Fixed In Version: subscription-manager-1.20.6-1
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 09:52:05 UTC


Attachments (Terms of Use)
Still see the url as "subscription.rhn.redhat.com" in custom url (90.96 KB, image/png)
2017-12-08 13:35 UTC, Shwetha Kallesh
no flags Details
Customurl point to subscription.rhsm.stage.redhat.com (96.94 KB, image/png)
2017-12-09 04:32 UTC, Shwetha Kallesh
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 09:52:27 UTC
Github candlepin subscription-manager pull 1721 None None None 2017-11-08 10:31:03 UTC

Description Shwetha Kallesh 2017-10-27 09:54:37 UTC
Description of problem:
subscription-manager-cockpit : Change the default url in cockpit to subscription.rhsm.redhat.com from subscription.rhn.redhat.com

Version-Release number of selected component (if applicable):
[root@dell-pe-fm120-1a ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 2.2.0-1
subscription management rules: 5.26
subscription-manager: 1.20.2-1.el7
python-rhsm: 1.20.2-1.el7

How reproducible:


Steps to Reproduce:
1.open cockpit subscription plugin
2.click 'Register' and 
3. Change url to custom url 

Actual results:
subscription.rhn.redhat.com is the default url that gets filled in the url field


Expected results:
subscription.rhsm.redhat.com should be the default url that gets filled in the url field

Additional info:

Comment 2 John Sefler 2017-10-27 13:41:40 UTC
Referencing original RFE Bug 1126501 for this default hostname url change.

Comment 4 Shwetha Kallesh 2017-12-08 13:33:56 UTC
Moving bug to failed_qa as I dont see the changes yet, please see the attachment.

[root@dhcp35-150 ~]# rpm -qa | grep subscription-manager
subscription-manager-rhsm-1.20.7-1.el7.x86_64
subscription-manager-cockpit-1.20.7-1.el7.noarch
subscription-manager-gui-1.20.7-1.el7.x86_64
subscription-manager-plugin-container-1.20.7-1.el7.x86_64
subscription-manager-1.20.7-1.el7.x86_64
subscription-manager-initial-setup-addon-1.20.7-1.el7.x86_64
subscription-manager-rhsm-certificates-1.20.7-1.el7.x86_64

Comment 5 Shwetha Kallesh 2017-12-08 13:35:24 UTC
Created attachment 1364846 [details]
Still see the url as "subscription.rhn.redhat.com" in custom url

Comment 6 Shwetha Kallesh 2017-12-08 13:51:25 UTC
[root@dhcp35-150 ~]# rpm -qa | grep cockpit
cockpit-packagekit-157-1.el7.x86_64
cockpit-ws-157-1.el7.x86_64
subscription-manager-cockpit-1.20.7-1.el7.noarch
cockpit-157-1.el7.x86_64
cockpit-bridge-157-1.el7.x86_64
cockpit-tests-157-1.el7.x86_64
cockpit-system-157-1.el7.noarch
cockpit-doc-157-1.el7.x86_64

Comment 8 Shwetha Kallesh 2017-12-09 04:32:55 UTC
Created attachment 1365158 [details]
Customurl point to subscription.rhsm.stage.redhat.com

Sorry about the wrong screenshot, I see the customurl pointing to "subscription.rhsm.stage.redhat.com" in the subscription-manager tab with following version of subscription-manager-cockpit

[root@dhcp35-150 ~]# rpm -qa | grep subscription-manager-cockpit
subscription-manager-cockpit-1.20.7-1.el7.noarch

[root@dhcp35-150 ~]# cat /etc/rhsm/rhsm.conf | grep hostname
# Server hostname:
hostname = subscription.rhsm.redhat.com

Comment 9 Shwetha Kallesh 2017-12-15 11:22:29 UTC
Default url now points to subscription.rhsm.redhat.com and not subscription.rhn.redhat.com with following version , so moving bug to verified

[root@bkr-hv01-guest15 ~]# rpm -qa | grep cockpit
cockpit-ws-154-2.el7.x86_64
cockpit-doc-154-2.el7.x86_64
cockpit-bridge-154-2.el7.x86_64
cockpit-154-2.el7.x86_64
cockpit-pcp-154-2.el7.x86_64
cockpit-system-154-2.el7.noarch
subscription-manager-cockpit-1.20.8-1.el7.noarch

Comment 12 errata-xmlrpc 2018-04-10 09:52:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681


Note You need to log in before you can comment on or make changes to this bug.