Bug 150718 - i386 gcc4 -Werror build fails; if -Werror removed, testsuite tests fail
i386 gcc4 -Werror build fails; if -Werror removed, testsuite tests fail
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Elena Zannoni
:
Depends On:
Blocks: FC4Blocker
  Show dependency treegraph
 
Reported: 2005-03-09 17:24 EST by Jason Vas Dias
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-27 09:41:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Vas Dias 2005-03-09 17:24:39 EST
Description of problem:

gdb cannot build under gcc4 for i386 with the standard spec file;
it gets compilation warnings which are converted to errors with
-Werror .

If you remove -Werror by setting enable_build_warnings="",
then many tests in the testsuite fail.

gdb seems to be generally unreliable and produces garbage output
when debugging gcc4 compiled code, so I thought rebuilding with
the new gcc4 might help, but then I encountered these problems.

Please fix gdb for the gcc4 build !

Version-Release number of selected component (if applicable):


$ rpm -q gdb gcc glibc binutils --queryformat
'%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH}\n'
gdb-6.3.0.0-0.29-i386
gcc-4.0.0-0.31-i386
glibc-2.3.4-14-i686
binutils-2.15.94.0.2-4-i386

How reproducible:

100%

Steps to Reproduce:
1. rpmbuild --rebuild gdb-6.3.0.0-0.29.src.rpm
  
Actual results:

Build fails


Expected results:

Build should succeed

Additional info:
Comment 1 Miloslav Trmač 2005-04-27 09:41:55 EDT
gdb-6.3.0.0-1.15 builds successfuly.

Note You need to log in before you can comment on or make changes to this bug.