Bug 1507246 - Add the ability to have the GlusterFS ansible script run more than once
Summary: Add the ability to have the GlusterFS ansible script run more than once
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.6.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.7.0
Assignee: Jose A. Rivera
QA Contact: Wenkai Shi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-28 19:28 UTC by Alexis Solanas
Modified: 2017-12-18 13:23 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-12-18 13:23:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3464 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.7 bug fix and enhancement update 2017-12-18 18:22:05 UTC

Description Alexis Solanas 2017-10-28 19:28:40 UTC
Description of problem:

 Currently it's not possible to run the ansible scripts more than once, or to updated the gluster topology once the cluster is running.

 The following upstream PR solves this issues: https://github.com/openshift/openshift-ansible/pull/5415


Version-Release number of the following components:

openshift-ansible-3.6.173.0.48-1.git.0.1609d30.el7.noarch 
ansible-2.3.1.0-3.el7.noarch
ansible 2.3.1.0
  config file = /etc/ansible/ansible.cfg
  configured module search path = Default w/o overrides
  python version = 2.7.5 (default, May  3 2017, 07:55:04) [GCC 4.8.5 20150623 (Red Hat 4.8.5-14)]


How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

 Ansible gluster playbook can only be run once
 
Expected results:

 Ansible gluster playbook can  be run several times 

Additional info:

Comment 2 Wenkai Shi 2017-11-07 05:45:19 UTC
Verified with version openshift-ansible-3.7.0-0.196.0.git.0.27cd7ec.el7, installer could wait for deploy-heketi pod now.

Comment 3 Javier Ramirez 2017-11-10 12:14:08 UTC
How feasible would be a backport to 3.6 ?

Comment 4 Jose A. Rivera 2017-11-10 12:50:49 UTC
Using openshift-ansible to deploy GlusterFS is not recommended in 3.6 since the playbooks are out of date. I would say we should not bother backporting this fix.

Comment 11 errata-xmlrpc 2017-12-18 13:23:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3464


Note You need to log in before you can comment on or make changes to this bug.