Bug 1507277 - [RFE][DR] - Vnic Profiles mapping in VMs register from data storage domain should be supported also for templates
Summary: [RFE][DR] - Vnic Profiles mapping in VMs register from data storage domain sh...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: eraviv
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks: 1518562 1548804
TreeView+ depends on / blocked
 
Reported: 2017-10-29 07:52 UTC by Maor
Modified: 2018-03-01 07:19 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
You can now select vNIC profiles for templates when registering them from a storage domain.
Clone Of:
Environment:
Last Closed: 2017-12-20 11:27:04 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+
ylavi: blocker+
mburman: testing_plan_complete+
ylavi: planning_ack+
danken: devel_ack+
myakove: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 84698 master MERGED common: vnic profiles mapping on template register 2017-11-30 14:57:51 UTC
oVirt gerrit 84712 master MERGED core: vnic profiles mapping on template register 2017-11-30 14:57:54 UTC
oVirt gerrit 84789 master MERGED restapi: vnic profiles mapping on template register 2017-11-30 14:57:57 UTC
oVirt gerrit 84796 master MERGED webadmin:vnic profiles mapping on template register 2017-11-30 14:58:06 UTC

Description Maor 2017-10-29 07:52:03 UTC
Description of problem:
oVirt supports mapping for VM's vnic profiles on register operation.
oVirt should support vnic profile for templates as well once registered.
This gap should be implemented for the DR requirement.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Meanwhile I've added the API so we won't be blocked on that 
see https://gerrit.ovirt.org/#/c/83072/

Comment 1 Yaniv Lavi 2017-10-29 15:07:25 UTC
I would want this addressed by GA of oVirt. Can you assign this out?

Comment 3 Red Hat Bugzilla Rules Engine 2017-11-21 12:47:36 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 7 Michael Burman 2017-12-03 08:51:30 UTC
Verified on - 4.2.0-0.0.master.20171201121510.gitb338573.el7.centos

Comment 8 Sandro Bonazzola 2017-12-20 11:27:04 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.