Bug 1507296 - sugar-browse-201 fails to start in f27 sugar 0.110.0
Summary: sugar-browse-201 fails to start in f27 sugar 0.110.0
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sugar-browse
Version: 27
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Simon Schampijer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Keywords:
: 1507292 (view as bug list)
Depends On:
Blocks: F27FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2017-10-29 12:05 UTC by satellitgo
Modified: 2017-10-31 15:39 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-10-31 15:39:25 UTC


Attachments (Terms of Use)

Description satellitgo 2017-10-29 12:05:42 UTC
Description of problem:
sugar-browse-201 fails to start in f27 sugar 0.110.0

Version-Release number of selected component (if applicable):
On Sat, Oct 28, 2017 at 11:26:20AM -0400, Frederick Grose wrote:
> After updating SoaS Fedora 27 beta with downloaded sugar-*-
> 0.110.0-6.fc27.noarch.rpm, sugar launches but Browse fails to.
> Here is the log:
> /usr/lib/python2.7/site-packages/sugar3/activity/activity.py:96: PyGIWarning:
> SugarExt was imported without specifying a version first. Use
> gi.require_version('SugarExt', '1.0') before import to ensure that the right
> version gets loaded. from gi.repository import SugarExt Traceback (most recent
> call last): File "/usr/bin/sugar-activity", line 220, in <module> main() File "
> /usr/bin/sugar-activity", line 164, in main module = __import__(module_name)
> File "/usr/share/sugar/activities/Browse.activity/webactivity.py", line 58, in
> <module> from collabwrapper.collabwrapper import CollabWrapper ImportError: No
> module named collabwrapper.collabwrapper Exited with status 1, pid 2117 data
> (<open file '<fdopen>', mode 'w' at 0x7f7e96f0f0c0>,
> '688cd1c0f3e7f674ceff5e6516598ab17dac0048')
>


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Does not start

Expected results:
Browse 201 to start

Additional info:

Comment 1 Fedora Blocker Bugs Application 2017-10-29 12:09:25 UTC
Proposed as a Freeze Exception for 27-final by Fedora user satellit using the blocker tracking app because:

 browse 201 is an essential application in sugar 0.110.0
sugar-desktop is a non blocking spin

Comment 2 Fedora Update System 2017-10-29 12:12:45 UTC
sugar-browse-201.2-1.fc27 sugar-speak-54-3.fc27 sugar-read-119-1.fc27 sugar-write-98.3-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5761c6fb93

Comment 3 Peter Robinson 2017-10-29 12:27:06 UTC
*** Bug 1507292 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2017-10-30 14:46:25 UTC
sugar-browse-201.2-1.fc27, sugar-read-119-1.fc27, sugar-speak-54-3.fc27, sugar-write-98.3-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5761c6fb93

Comment 5 satellitgo 2017-10-30 15:49:58 UTC
https://bodhi.fedoraproject.org/updates/FEDORA-2017-5761c6fb93

sugar-browse-201.2-1.fc27.noarch.rpm fixes browse in f27 sugar 0.110.0 installed with software install in f27 workstation starts in sugar-runner sugar-read sugar-speak sugar-write tested and work

Comment 6 Geoffrey Marr 2017-10-30 19:59:56 UTC
Discussed during the 2017-10-30 blocker review meeting: [1]

The decision to classify this bug as an AcceptedFreezeException was made as this bug prevents a non-release blocking desktop from working, as is obviously important to fix for that reason.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-10-30/f27-blocker-review.2017-10-30-16.00.txt

Comment 7 Fedora Update System 2017-10-31 15:39:25 UTC
sugar-browse-201.2-1.fc27, sugar-read-119-1.fc27, sugar-speak-54-3.fc27, sugar-write-98.3-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.