Bug 1507316 - [downstream clone - 4.1.7] Engine and audit logs don't indicate if a commit or undo was issued during a snapshot preview
Summary: [downstream clone - 4.1.7] Engine and audit logs don't indicate if a commit o...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.5
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: ovirt-4.1.7
: ---
Assignee: shani
QA Contact: Avihai
URL:
Whiteboard:
Depends On: 1500812
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-29 15:44 UTC by rhev-integ
Modified: 2019-04-28 11:15 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1500812
Environment:
Last Closed: 2017-11-07 17:27:54 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3138 0 normal SHIPPED_LIVE Red Hat Virtualization Manager (ovirt-engine) 4.1.7 2017-11-07 22:22:33 UTC
oVirt gerrit 82939 0 master MERGED core: Indicate commit or undo during a snapshot preview 2017-10-29 15:44:46 UTC
oVirt gerrit 83363 0 ovirt-engine-4.1 MERGED core: Indicate commit or undo during a snapshot preview 2017-10-30 09:48:57 UTC

Description rhev-integ 2017-10-29 15:44:21 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1500812 +++
======================================================================

Description of problem:

When a snapshot preview is performed, the final step is to either 'commit' or 'undo'. 

The audit logs show the same for both options;

 Snapshot-Preview snap1 for VM abc was initiated by admin@internal-authz.
 Snapshot-Preview snap1 for VM abc has been completed.
 Restoring VM abc from snapshot started by user admin@internal-authz.
 VM abc restoring from Snapshot has been completed.


A subset of the engine logs is the same;

2017-10-11 10:04:09,636-04 INFO  [org.ovirt.engine.core.bll.snapshots.RestoreAllSnapshotsCommand] (default task-20) [38193bfc-4d78-4f6a-a3d6-9b1099ede590] Running command: RestoreAllSnapshotsCommand internal: false. Entities affected :  ID: 1438e077-13cf-43ba-8b83-85aec440e812 Type: VMAction group MANIPULATE_VM_SNAPSHOTS with role type USER

2017-10-11 10:04:09,956-04 INFO  [org.ovirt.engine.core.bll.snapshots.RestoreFromSnapshotCommand] (default task-20) [38193bfc-4d78-4f6a-a3d6-9b1099ede590] Running command: RestoreFromSnapshotCommand internal: true. Entities affected :  ID: 00000000-0000-0000-0000-000000000000 Type: Storage

2017-10-11 10:04:10,059-04 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.DestroyImageVDSCommand] (default task-20) [38193bfc-4d78-4f6a-a3d6-9b1099ede590] START, DestroyImageVDSCommand( DestroyImageVDSCommandParameters:{runAsync='true', storagePoolId='00000001-0001-0001-0001-000000000311', ignoreFailoverLimit='false', storageDomainId='6067c360-2e51-4302-ab74-1c7ab6acba43', imageGroupId='550c76a6-a626-4f75-a36e-cd27d3c8928d', imageId='00000000-0000-0000-0000-000000000000', imageList='[75785662-dbd5-45f6-8047-8d4e64f5939f]', postZero='false', force='true'}), log id: e9aafca

2017-10-11 10:04:11,298-04 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.DestroyImageVDSCommand] (default task-20) [38193bfc-4d78-4f6a-a3d6-9b1099ede590] FINISH, DestroyImageVDSCommand, log id: e9aafca

2017-10-11 10:04:11,535-04 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-20) [38193bfc-4d78-4f6a-a3d6-9b1099ede590] EVENT_ID: USER_RESTORE_FROM_SNAPSHOT_START(1,190), Correlation ID: 38193bfc-4d78-4f6a-a3d6-9b1099ede590, Job ID: 53e24e2f-38f2-4419-8232-6199c981e8b9, Call Stack: null, Custom Event ID: -1, Message: Restoring VM abc from snapshot started by user admin@internal-authz.

2017-10-11 10:04:25,462-04 INFO  [org.ovirt.engine.core.bll.snapshots.RestoreFromSnapshotCommand] (DefaultQuartzScheduler10) [38193bfc-4d78-4f6a-a3d6-9b1099ede590] Ending command 'org.ovirt.engine.core.bll.snapshots.RestoreFromSnapshotCommand' successfully.

017-10-11 10:04:25,536-04 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (DefaultQuartzScheduler10) [] EVENT_ID: USER_RESTORE_FROM_SNAPSHOT_FINISH_SUCCESS(100), Correlation ID: 38193bfc-4d78-4f6a-a3d6-9b1099ede590, Job ID: 53e24e2f-38f2-4419-8232-6199c981e8b9, Call Stack: null, Custom Event ID: -1, Message: VM abc restoring from Snapshot has been completed.


There are no references to "commit" or "undo".


Version-Release number of selected component (if applicable):

RHV 4.1


How reproducible:

100%


Steps to Reproduce:
1. Perform a snapshot preview.
2. 'Commit', check logs.
3. Repeat, choose 'undo', check logs.


Actual results:


Expected results:


Additional info:

(Originally by Gordon Watson)

Comment 6 Avihai 2017-11-02 07:11:31 UTC
verified on engine 4.1.7.5-0.1

Comment 9 errata-xmlrpc 2017-11-07 17:27:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3138


Note You need to log in before you can comment on or make changes to this bug.