Bug 150733 - RHEL 3 Update 3 dhcp fails on Dell 1750, BroadCom BCM5704
RHEL 3 Update 3 dhcp fails on Dell 1750, BroadCom BCM5704
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-09 19:35 EST by Michael T. Halligan
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-04 14:40:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael T. Halligan 2005-03-09 19:35:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7.6) Gecko/20050223 Firefox/1.0.1

Description of problem:
When attempting to use the kickstart/netboot images for RHEL3U4, to do
a PXE install, DHCP fails. The first DHCP request works fine, and then
the linux install loads, but the linux dhcp process fails without any
error message.  This is true both with Update 3, and Update 4. The
images for Update 1 and Update 2 work fine.

Version-Release number of selected component (if applicable):
2.4.21-27.ELBOOT

How reproducible:
Always

Steps to Reproduce:
1.Pxeboot the netboot image
2. Watch the dhcp fail.

Actual Results:  Once the netboot image is loaded, the box ceases to
send out any network traffic. It sits at the network configuration screen.

Expected Results:  The server should send a DHCP message, get it's IP
address, and get it's next-server so it knows what kickstart file to grab.

Additional info:

I believe this to be a bug with the tg3 driver. This makes pxebooting
impossible.
Comment 1 Michael T. Halligan 2005-03-10 16:00:13 EST
Correction, this doesn't make "pxebooting" impossible, because the pxeboot
process works well. It's after the pxe boot, once the redhat image is loaded,
where things fail..
Comment 2 John W. Linville 2005-03-11 10:49:43 EST
Can you see any non-PXE DHCP traffic on the wire?  Perhaps you can
attach the output of something like tcpdump or ethereal running at the
DHCP server (hopefully on an isolated network)?  Thanks!
Comment 3 John W. Linville 2005-03-15 09:41:05 EST
Is STP enabled on the switch port?  If so, can you disable it and try
again?

When the tg3 driver loads, it will re-init the hardware which probably
causes the link to go down.  If STP is enabled, it could take 30+
seconds for the link to become usable again.  That may be long enough
to cause DHCP to fail.
Comment 4 John W. Linville 2005-05-04 14:40:26 EDT
Closed due to lack of response.  Please reopen if the requested information 
becomes available. 

Note You need to log in before you can comment on or make changes to this bug.