Bug 1507425 - When logging out and in again, you get: WebSocket is already in CLOSING or CLOSED state
Summary: When logging out and in again, you get: WebSocket is already in CLOSING or CL...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M3
: 13.0 (Queens)
Assignee: Honza Pokorny
QA Contact: Udi
URL:
Whiteboard:
: 1514023 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-30 08:57 UTC by Udi
Modified: 2018-06-27 13:39 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-ui-8.3.1-0.20180303225336.57e3d96.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:38:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1746583 None None None 2018-01-31 19:30:23 UTC
OpenStack gerrit 539642 None master: MERGED tripleo-ui: Stop logging over websocket on logout (Iaf365d78cf5e2b35c4f035a9f068266131940553) 2018-03-21 13:40:04 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:39:58 UTC

Description Udi 2017-10-30 08:57:46 UTC
Description of problem:
You see this error in the console when logging out and back in to the director ui:

ZaqarWebSocketService.js:95 WebSocket is already in CLOSING or CLOSED state.


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-7.4.3-0.20171023133305.8616195.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Press F12 to see the console output
2. Log out and back in

Comment 4 Jiri Tomasek 2018-01-31 16:01:11 UTC
This error happens when user is logged out. At that point, app disconnects from zaqar websocket and logger still tries to send messages. At that point we need to switch to storing the messages and flush them once user logs back in

Comment 5 Udi 2018-02-07 06:39:42 UTC
*** Bug 1514023 has been marked as a duplicate of this bug. ***

Comment 8 Udi 2018-04-04 11:24:46 UTC
Verified: openstack-tripleo-ui-8.3.1-2.el7ost.noarch

Comment 10 errata-xmlrpc 2018-06-27 13:38:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.