Bug 150743 - kernel panic in rwsem.h
Summary: kernel panic in rwsem.h
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
: ---
Assignee: David Howells
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-10 03:55 UTC by Dave Miller
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: 2.6.9-11.11.EL (U2)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-09 09:23:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Miller 2005-03-10 03:55:09 UTC
Description of problem:
kernel panicked.  The message on the console mentioned rwsem.h. 
Filesystem access was lost, so no panic log was recoverable, and the
colo admin didn't get a screenshot before rebooting. :(

Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-5.0.3.EL

How reproducible:
First time it's happened, hope it doesn't happen again.

Steps to Reproduce:
1. ??
  
Additional info:
This is our second kernel panic on this box with this kernel, but
since the panic error was different this time I filed a new bug.

Because of the previous experience, we already had
kernel-smp-2.6.9-6.16.EL installed and configured to boot into, so we
picked up that kernel on the post-panic reboot.  Previous issue with
this machine is bug 150044.

Comment 1 David Howells 2005-06-30 14:36:01 UTC
I don't know what I can do about this. Are you sure that "rwsem.h" was 
mentioned and not "rwsem.c" or some function whose name contains "rwsem"? 
 
We do have a patch to fix a problem with R/W semaphores that so far only crops 
up in conjunction with AIO as far as I know. Are you using AIO? 

Comment 2 Dave Miller 2005-08-08 18:02:38 UTC
I don't know of any way to get additional info, unfortunately the tech at the
scene at the time didn't have a camera to get a screenshot of the console before
rebooting it when it happened, and we were going from his memory to describe
what happened.  It's been 5 months (a 3 kernel upgrades) since then, and it
hasn't happened again, and that machine's been under pretty serious load the
entire time. :)

I would just go ahead and close this out as unreproducable or something.

Comment 3 David Howells 2005-08-09 09:23:22 UTC
Okay. I suspect this will be fixed by a patch added to RHEL4 to make  
rwsems interrupt-safe, assuming it wasn't caused indirectly by some other bug. 
This patch will be in RHEL-4 U2. Let us know if it happens again.  


Note You need to log in before you can comment on or make changes to this bug.