Bug 150749 - possible mismatch between header and libraries
possible mismatch between header and libraries
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: db4 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
http://lisas.de/~adrian/rpm/jabberd-2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-10 02:05 EST by Adrian Reber
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 15:26:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrian Reber 2005-03-10 02:05:10 EST
Description of problem:

I am building the jabber server which uses db4 as backend storage. If I compile
it with rawhide db4 and let it run on rawhide it crashes when using functions
from db4:

 Program received signal SIGSEGV , Segmentation fault.
[Switching to Thread -1208981824 (LWP 16359)]
0x00000000 in ?? ()
(gdb) bt
#0 0x00000000 in ?? ()
#1 0x080537cb in st_db_init (drv=0x863fd10) at storage_db.c:520
#2 0x080526fd in storage_add_type (st=0x86407a0 , driver=0x808edb6 " db " ,
type=0x0) at storage.c:190
#3 0x08053176 in storage_new (sm=0x863a008) at storage.c:104
#4 0x0804b762 in main (argc=3 , argv=0xbffc94e4) at main.c:238

I tried to compile it with gcc 4.0 and gcc 3.3 and it always the same.
If I compile it under FC-3 and let it run under rawhide it works perfectly. I
have also tried to replace db4/db.h in my rawhide installation with the header
from db4 from FC-3 and there is also no crash and that is way I think it might
be a mismatch between the headers in db4 and the installed libraries.

Version-Release number of selected component (if applicable):
db4-4.3.27-2
gcc-4.0.0-0.30

http://cvs.fedora.redhat.com/viewcvs/rpms/jabberd/devel/jabberd.spec?root=extras&rev=1.3&view=auto
Comment 1 Jeff Johnson 2005-03-10 07:15:48 EST
Have you upgraded db4-devel?
Comment 2 Adrian Reber 2005-03-10 07:18:49 EST
Yes:

db4-devel-4.3.27-2
Comment 3 Adrian Reber 2005-03-21 16:17:22 EST
I have tested this some more and found out that this only happens on a system
which was installed as FC3 and then (partly) updated to rawhide.
If I, however, compile jabberd in a freshly installed chroot with the current
development tree the described error does not happen. So the error seems to be
somewhere else in my installation.
Comment 4 Paul Nasrat 2005-11-28 15:26:19 EST
Closing based on last comment due to hybrid setup.

Note You need to log in before you can comment on or make changes to this bug.