Bug 150750 - .ics file brings Evolution to a swift end
Summary: .ics file brings Evolution to a swift end
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: evolution   
(Show other bugs)
Version: 3.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard: u5regress
Keywords: Regression
Depends On:
Blocks: 170445
TreeView+ depends on / blocked
 
Reported: 2005-03-10 08:19 UTC by Chris Lee
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-21 14:29:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace of Evolution crash (6.34 KB, text/plain)
2005-03-17 22:09 UTC, Edward Rousseau
no flags Details

Description Chris Lee 2005-03-10 08:19:28 UTC
Description of problem:
Evolution crashes when I attempt to import an ICS file.


Version-Release number of selected component (if applicable):
evolution-1.4.5-12


How reproducible:
Once, haven't reproduced again yet


Steps to Reproduce:
1. Launch Evolution
2. Import, set to single file, leave file type as 'Detect'
3. Attempt to import the Bills.ics file
  
Actual results:
Evolution segfaults

Expected results:
Evolution displays the contents of the ICS file in the calendar view.

Other notes:
This .ics file was generated by iCal. Not sure if that has anything to do with
the crash, but I thought it was worth mentioning how I generated this file.

Comment 2 Dave Malcolm 2005-03-17 02:10:22 UTC
FWIW I just now successfully imported the calendar on a machine running rawhide
(evo 2.2, e-d-s 1.2); was promted for file type; chose ics over vcf

Comment 3 Edward Rousseau 2005-03-17 20:55:56 UTC
Dave, On i386 this does not work either. There is no segfault but the text for
the calendar items does not show in the Day view but the days are bolded in the
numerical calendar pane.

Comment 4 Edward Rousseau 2005-03-17 20:58:21 UTC
Follow up ... above I was usng automatic and it defaulted to .ics. If I force a
.vcf Evolution crashes.

Comment 5 Edward Rousseau 2005-03-17 22:09:06 UTC
Created attachment 112111 [details]
Backtrace of Evolution crash

I had to import the .ics file twice as .vcf. The first import errored but did
not crash evolution. The second import did. Also there is no crash if you set
the target of the import to a new calendar. Crashing happens only when tryng to
import the file into the existing default calendar.

Comment 6 Dave Malcolm 2005-08-24 21:41:35 UTC
Looks like a dup of bug 157352.


Is this fixed with the latest packages?


Note You need to log in before you can comment on or make changes to this bug.