Bug 150752 - su hangs when switching to root for second time
su hangs when switching to root for second time
Status: CLOSED DUPLICATE of bug 87598
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-10 04:18 EST by Wayne
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-11 07:26:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Wayne 2005-03-10 04:18:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
I'm having some problems with the su command. I recently installed fedora and updated it and I am getting delay problems with the su commend.

I'm using gnome console.

When i type su and then enter the password it works fine.
If i then switch back to a user and then try su again it takes ages to switch to the root but if i open a new console window and type su it's instant.

I've also tried this with xterm and i get the same result.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. open gnome-console
2. type su
3. type password
4. type su user
5. type su  

Actual Results:  On the second and consecutive su (to the root) command it hangs. It does eventually switch to the root

Expected Results:  It should be an instant switch to the root 

Additional info:
Comment 1 Tim Waugh 2005-04-11 07:26:00 EDT

*** This bug has been marked as a duplicate of 87598 ***

Note You need to log in before you can comment on or make changes to this bug.