Bug 150753 - FORWARD_IPV4 not used
FORWARD_IPV4 not used
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 150754 150755 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-10 04:28 EST by Steve Hill
Modified: 2014-03-16 22:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-10 11:52:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Hill 2005-03-10 04:28:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
/usr/share/doc/initscripts-7.93.5/sysconfig.txt states that the FORWARD_IPV4 option is still valid in /etc/sysconfig/network for turning on IPv4 forwarding.  However, the option does not appear to work and none of the network scripts seem to look for it.

Even worse, the /etc/rc.d/init.d/network script disables IPv4 forwarding on stop, so restarting the network will disable forwarding which was turned on by another means (e.g. set in /etc/sysctl.conf or otherwise).

Version-Release number of selected component (if applicable):
initscripts-7.93.5-1

How reproducible:
Always

Steps to Reproduce:
1. Set FORWARD_IPV4=yes
2. Start network
3. Note that forwarding is still disabled despite (1)
4. sysctl -w net.ipv4.ip_forward=1
5. Note that forwarding is now on
6. /etc/rc.d/init.d/network restart
7. Note that forwarding has now been turned off again despite the option (1)

Actual Results:  IPv4 forwarding cannot be turned on by recommended means.  Forcing it on manually by sysctl works but it turned off again upon network restart.

Expected Results:  FORWARD_IPV4=yes option should be honoured as documented.  Infact I think this should probably also be the default if FORWARD_IPV4=no is not specified.

Additional info:
Comment 1 Bill Nottingham 2005-03-10 11:52:14 EST
It's supposed to be enabled by editing sysctl.conf.

In fact, if you look at the documentation:

  obsoleted values from earlier releases:

    FORWARD_IPV4=yes|no
      This setting has been moved into net.ipv4.ip_forward setting
      in /etc/sysctl.conf. Setting it to 1 there enables IP forwarding,
      setting it to 0 disables it (which is the default for RFC compliance).
Comment 2 Steve Hill 2005-03-11 05:11:28 EST
*** Bug 150755 has been marked as a duplicate of this bug. ***
Comment 3 Steve Hill 2005-03-11 05:11:57 EST
*** Bug 150754 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.