Bug 1507557 - Memory and Memory Utilization panels
Summary: Memory and Memory Utilization panels
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-monitoring-integration
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Ankush Behl
QA Contact: Sweta Anandpara
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-30 14:48 UTC by Filip Balák
Modified: 2017-12-18 04:39 UTC (History)
6 users (show)

Fixed In Version: tendrl-ui-1.5.4-1.el7rhgs.noarch.rpm
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:39:14 UTC
Target Upstream Version:


Attachments (Terms of Use)
Memory and Memory Utilization panels (22.65 KB, image/png)
2017-10-30 14:48 UTC, Filip Balák
no flags Details
memory_utilization_new (38.76 KB, image/png)
2017-11-20 10:46 UTC, Sweta Anandpara
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC
Github Tendrl monitoring-integration issues 164 None None None 2017-11-07 12:48:30 UTC

Description Filip Balák 2017-10-30 14:48:57 UTC
Created attachment 1345468 [details]
Memory and Memory Utilization panels

Description of problem:
In Memory Utilization panel in Hosts dashboard are chart legend items `Buffered` and `cached` in one row. These items should be placed on separated rows. `cached should start with capital letter as the rest of the items.

Memory Utilization panel contains measure `Total Used`. It seems to consist of MemFree+Buffers+Cached from /proc/meminfo. I can not find any definitions for this metric (man free). Maybe it should not be used in the chart if it is no official described metric. It can be confusing for user. This metric can be replaced by MemAvailable from /proc/meminfo.

Name of panel `Memory` should reflect what it shows. Maybe something like `Memory (Free+Cached)`. The most user friendly would by to name it `Memory Available` and place there values representing metric MemAvailable from /proc/meminfo or available from free.

Version-Release number of selected component (if applicable):
tendrl-api-httpd-1.5.3-2.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-node-agent-1.5.3-3.el7rhgs.noarch
tendrl-ui-1.5.3-2.el7rhgs.noarch
tendrl-grafana-plugins-1.5.3-2.el7rhgs.noarch
tendrl-notifier-1.5.3-1.el7rhgs.noarch
tendrl-ansible-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.3-1.el7rhgs.noarch
tendrl-api-1.5.3-2.el7rhgs.noarch
tendrl-monitoring-integration-1.5.3-2.el7rhgs.noarch
glusterfs-3.8.4-50.el7rhgs.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Import cluster with volume into tendrl.
2. Open Grafana and got to `Hosts` dashboard.
3. Check Memory and Memory Utilization panels

Actual results:


Expected results:


Additional info:

Comment 1 Nishanth Thomas 2017-11-06 17:41:57 UTC
What is the 'official' source you are comparing against?
The current implementation done(also there were some changes) by consulting UXD and others(esp the 'Total').

Also I do not Tendrl should 100% adhere to the same stats whuch written in linux man pages. What we currently implemented would suffice with documentation. Please call out if you see incorrect data anywhere.

Comment 2 Filip Balák 2017-11-08 12:55:26 UTC
I am little concerned that for the `Total Used` value is not clear what it represents. There exist some settled terms that are used by linux and I think that these should be reflected there. At first glance I do not know what is difference between `Total Used` and `Used`. To use `Available memory` would be better.

Comment 3 Ankush Behl 2017-11-09 04:45:25 UTC
@fbalak@redhat.com  `Available memory` we are already showing in single stat panel.I will remove from the "Total Used" from the graph which is actually creating the confusion.

Comment 4 Filip Balák 2017-11-10 10:01:51 UTC
@anbehl@redhat.com It would probably be good to remove it because today I got mail from tendrl notifier that memory on my nodes have breched threshold but when I looked on grafana there was cached memory on 50% which is calculated in Total Used. Actual Used was just around 20%.

Comment 6 Sweta Anandpara 2017-11-20 10:46:30 UTC
Created attachment 1355674 [details]
memory_utilization_new

Comment 7 Sweta Anandpara 2017-11-20 10:47:56 UTC
I meant to take qa_contact. Sorry!

Comment 10 errata-xmlrpc 2017-12-18 04:39:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.