Bug 1507573 - Charts which values can not be negative shouldn't show negative labels on axis
Summary: Charts which values can not be negative shouldn't show negative labels on axis
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-monitoring-integration
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Ankush Behl
QA Contact: Martin Kudlej
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-30 15:18 UTC by Filip Balák
Modified: 2017-12-18 04:39 UTC (History)
2 users (show)

Fixed In Version: tendrl-monitoring-integration-1.5.4-3.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:39:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
Swap Utilization panel (9.08 KB, image/png)
2017-10-30 15:18 UTC, Filip Balák
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC
Github https://github.com/Tendrl monitoring-integration issues 232 None None None 2017-11-07 07:02:20 UTC

Description Filip Balák 2017-10-30 15:18:40 UTC
Created attachment 1345514 [details]
Swap Utilization panel

Description of problem:
In Hosts dashboard are several line charts with metrics that can not have negative values but their axis shows labels with negative values and suggests that values in this chart can be negative.
Panels: Swap Utilization, IOPS, Dropped Packets Per Second, Errors Per Second

Version-Release number of selected component (if applicable):
tendrl-api-httpd-1.5.3-2.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-node-agent-1.5.3-3.el7rhgs.noarch
tendrl-ui-1.5.3-2.el7rhgs.noarch
tendrl-grafana-plugins-1.5.3-2.el7rhgs.noarch
tendrl-notifier-1.5.3-1.el7rhgs.noarch
tendrl-ansible-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.3-1.el7rhgs.noarch
tendrl-api-1.5.3-2.el7rhgs.noarch
tendrl-monitoring-integration-1.5.3-2.el7rhgs.noarch
glusterfs-3.8.4-50.el7rhgs.x86_64

How reproducible:
90%

Steps to Reproduce:
1. Import cluster with volume into tendrl.
2. Open Grafana and go to `Hosts` dashboard.
3. Check affected panels with line charts.

Actual results:
On some line charts with metrics that can not have negative values are displayed  negative values on axis.

Expected results:
Axis should contain only positive values.

Additional info:

Comment 1 Filip Balák 2017-11-13 15:05:34 UTC
Looks ok -> VERIFIED

Tested with:
tendrl-node-agent-1.5.4-2.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.4-2.el7rhgs.noarch
tendrl-api-1.5.4-2.el7rhgs.noarch
tendrl-api-httpd-1.5.4-2.el7rhgs.noarch
tendrl-monitoring-integration-1.5.4-3.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-notifier-1.5.4-2.el7rhgs.noarch
tendrl-ansible-1.5.4-1.el7rhgs.noarch
tendrl-ui-1.5.4-2.el7rhgs.noarch
tendrl-grafana-plugins-1.5.4-3.el7rhgs.noarch

Comment 4 errata-xmlrpc 2017-12-18 04:39:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.