Bug 150766 - MAKEDEV doesn't like CVS directory in /etc/makedev.d
Summary: MAKEDEV doesn't like CVS directory in /etc/makedev.d
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: MAKEDEV   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Nalin Dahyabhai
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-10 12:51 UTC by Peter Bieringer
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: 4.19-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-17 21:01:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Bieringer 2005-03-10 12:51:12 UTC
Description of problem:
We're using a system CVS to track configuration changes properly.

udev isn't smart enough during running through its configuration
directory and an error message now.




Version-Release number of selected component (if applicable):
udev-039-10.8.EL4

How reproducible:
Always

Steps to Reproduce:
1. create directory in /etc/makedev.d
2. reboot
    

Actual Results:  Starting udev:  error: /etc/makedev.d/CVS is not a
regular file

Expected Results:  No such error message

Additional info:

It looks like udev only expect files in /etc/makedev.d, so why not
filtering the directory open for files only or skip file if it is a
directory?

Comment 2 Harald Hoyer 2005-03-11 11:53:03 UTC
this is makedev

Comment 3 Nalin Dahyabhai 2005-03-17 20:47:37 UTC
If you invoke MAKEDEV with the "-i" flag, it will issue a warning instead of an
error if it runs into a problem reading its configuration.

Comment 4 Peter Bieringer 2005-03-18 13:22:35 UTC
How to tell using "-i" udev? ;-)

BTW: can I test the rawhide package on RHEL4?

Comment 5 Harald Hoyer 2005-03-18 15:03:29 UTC
Peter, edit /sbin/start_udev and change the MAKEDEV call.

yes, you can _test_ the rawhide package on RHEL4

Comment 6 Peter Bieringer 2005-04-14 08:43:41 UTC
Can confirm that it works now using following version:

http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/MAKEDEV-3.19-1.i386.rpm



Note You need to log in before you can comment on or make changes to this bug.