Bug 1507731 - kdumpctl won't check if the modified time of makedumpfile is newer
Summary: kdumpctl won't check if the modified time of makedumpfile is newer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools
Version: 7.5
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: lijiang
QA Contact: zhijwang
URL:
Whiteboard:
Depends On:
Blocks: 1548445 1549423
TreeView+ depends on / blocked
 
Reported: 2017-10-31 02:53 UTC by Qiao Zhao
Modified: 2018-10-30 11:31 UTC (History)
1 user (show)

Fixed In Version: kexec-tools-2.0.15-14
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 11:29:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3240 None None None 2018-10-30 11:31:07 UTC

Description Qiao Zhao 2017-10-31 02:53:10 UTC
Description of problem:

Like summary, kdumpctl should check makedumpfile timestamp.
Here is some test log:
[root@hp-z230 ~]# kdumpctl restart
kexec: unloaded kdump kernel
Stopping kdump: [OK]
kexec: loaded kdump kernel
Starting kdump: [OK]

[root@hp-z230 ~]# ls -l /sbin/makedumpfile 
-rwxr-xr-x. 1 root root 360480 Jun 27 21:28 /sbin/makedumpfile
[root@hp-z230 ~]# touch /sbin/makedumpfile 
[root@hp-z230 ~]# ls -l /sbin/makedumpfile 
-rwxr-xr-x. 1 root root 360480 Oct 31 10:49 /sbin/makedumpfile
[root@hp-z230 ~]# kdumpctl restart
kexec: unloaded kdump kernel
Stopping kdump: [OK]
kexec: loaded kdump kernel
Starting kdump: [OK]


Kdumpctl should rebuild initramfs file when use new makedumpfile file.

Version-Release number of selected component (if applicable):
7.4 GA kernel/kexec-tools/makedumpfile package.

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 errata-xmlrpc 2018-10-30 11:29:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3240


Note You need to log in before you can comment on or make changes to this bug.