Bug 150780 - openoffice.org-core should obsolete openoffice.org-lib
openoffice.org-core should obsolete openoffice.org-lib
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-10 10:29 EST by Hans de Goede
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-10 10:41:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2005-03-10 10:29:46 EST
Description of problem:

I tried yum updating FC3+updates -> rawhide, but it failed with an 
unresolved dependency in openoffice.org-libs, the problem is that 
rawhide doesn't have openoffice.org-libs anymore, so the old one should 
be removed by yum, which requires an obsolete in openoffice.org-core 
(which now contains the libs)
Comment 1 Caolan McNamara 2005-03-10 10:37:58 EST
strange.

rpm -qp --obsoletes openoffice.org-core-1.9.83-1.i386.rpm
openoffice.org
openoffice.org-libs
openoffice.org-i18n
openoffice.org-kde

What version of openoffice.org-core was this happening with do you know ?
Comment 2 Hans de Goede 2005-03-10 10:41:56 EST
[hans@cq229 ~]$ rpm -q openoffice.org-core
openoffice.org-core-1.9.83-1

Hmm, maybe a yum bug? It gave a depsolve error that
openoffice.org-libs required libdb_cxx.so.4.2 .

Hmm, this was a partial upgrade (I only wanted/needed kde from
rawhide) so maybe openoffice didn't get sucked in and as such ooo-libs
didn't get obsoleted, but db4 did get upgraded because some dep needed
a newer db4. I should have tried adding openoffice.org to the yum
update command cmdline I guess.

Anyways closing...



Note You need to log in before you can comment on or make changes to this bug.