This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 150785 - Message headers view needs a scrollbar
Message headers view needs a scrollbar
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: thunderbird (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-10 11:04 EST by Mike Gahagan
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-15 13:58:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 223132 None None None Never

  None (edit)
Description Mike Gahagan 2005-03-10 11:04:04 EST
Description of problem:

When viewing full headers on an email message with large numbers of headers, you
cannot view all of the headers nor read the message as the headers section of
the message always shows up without a scrollbar regardless of the size of the
window.

I marked this as x86 only because thats what I noticed the problem on, this is
likely a problem across all arch's.

Version-Release number of selected component (if applicable):

thunderbird-1.0-1.1.EL4

How reproducible:

Always. It only requires an email with a large number of headers, i.e. messages
from Lotus Notes users.

Steps to Reproduce:
1.Get an email message with lots of headers.
2.Turn on viewing of all headers (View->headers->all)
3.Notice that all you see in the message window are the headers which you cannot
scroll past to see the rest of the headers or read the message.
  
Actual results:

Only the first set of headers show up and completely cover the message window
with no way to scroll through them.

Expected results:

A scrollbar to move through the long list of headers like you have with the
message content.

Additional info:

Workaround: Save the message as a file and open it with your favoriate text
editor or viewer.
Comment 1 Matěj Cepl 2007-05-14 12:45:43 EDT
Could very well reproduce with thunderbird-1.5.0.10-0.1.el4 -- To: header of
some of my messages are readable only in Source view.
Comment 2 Christopher Aillon 2007-05-15 13:58:40 EDT
Yeah, this is a problem and is sadly unlikely to get fixed in 1.5 especially now
that 2.0 is out, although it exhibits the same problem there.

My preferred workaround is to have minimal headers on by default and if I want
to see the entire header set, Ctrl+U will pop up the source.

https://bugzilla.mozilla.org/show_bug.cgi?id=223132

Note You need to log in before you can comment on or make changes to this bug.