Bug 1507856 - OpenDaylight Jolokia services uses the default user and password instead of the supplied values
Summary: OpenDaylight Jolokia services uses the default user and password instead of t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Michael Vorburger
QA Contact: Tomas Jamrisko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-31 10:24 UTC by Itzik Brown
Modified: 2018-10-18 07:24 UTC (History)
9 users (show)

Fixed In Version: opendaylight-8.0.0-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2018-06-27 13:38:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github rhuss jolokia pull 358 None None None 2018-02-05 20:03:47 UTC
Launchpad 1728885 None None None 2017-10-31 10:26:24 UTC
OpenDaylight Bug AAA-147 None None None 2017-11-07 16:09:17 UTC
OpenDaylight gerrit 68069 None None None 2018-02-09 08:24:12 UTC
OpenDaylight gerrit 68070 None None None 2018-02-09 08:25:20 UTC
OpenDaylight gerrit 68072 None None None 2018-02-09 08:25:00 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:39:58 UTC

Description Itzik Brown 2017-10-31 10:24:12 UTC
Description of problem:

When querying the jolokia service in OpenDaylight it's possible only when using a user and a password admin:admin even when setting using other values for OpenDaylightUsername and OpenDaylightPassword in the environment files.

The query is:
curl -H "Content-Type:application/json" -u someuser:somepassword http://192.168.80.80:8081/jolokia/read/org.opendaylight.controller:Category=Shards,name=member-1-shard-inventory-config,type=DistributedConfigDatastor

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-7.0.3-0.20171023134948.el7ost.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2017-10-31 11:11:24 UTC
This bugzilla has been removed from the release since it has not been triaged, and needs to be reviewed for targeting another release.

Comment 2 Michael Vorburger 2017-11-01 12:28:30 UTC
If https://lists.opendaylight.org/pipermail/dev/2017-February/003343.html which Janki found is still accurate (which without proof to the contrarym I would assume it is), then it would seem that this "bug" is simply because in upstream ODL the Jolokia uid/pwd is currently hard-coded to admin/admin - see https://github.com/opendaylight/controller/blob/master/opendaylight/commons/jolokia/src/main/resources/org.jolokia.osgi.cfg

I'll see if we can engage Ryan upstream to do the neccessary work.  PMs, please NB that from an upstream perspective this is sort of more of an Enhancement, which will go into master, instead of a kind of "quick bug fix"...

Comment 3 Janki 2017-11-01 13:03:20 UTC
TripleO, via puppet-odl, configures username/password through idmtool which is incorporated in AAA project of ODL controller. Jolokia does not authenticate via AAA but has the values hard-coded (details in comment by Michael). So this is not a TripleO.

Comment 4 Itzik Brown 2017-11-01 13:16:08 UTC
(In reply to Janki from comment #3)
> TripleO, via puppet-odl, configures username/password through idmtool which
> is incorporated in AAA project of ODL controller. Jolokia does not
> authenticate via AAA but has the values hard-coded (details in comment by
> Michael). So this is not a TripleO.

So should we change the component to OpenDaylight?

Comment 5 Janki 2017-11-01 13:55:39 UTC
(In reply to Itzik Brown from comment #4)
> (In reply to Janki from comment #3)
> > TripleO, via puppet-odl, configures username/password through idmtool which
> > is incorporated in AAA project of ODL controller. Jolokia does not
> > authenticate via AAA but has the values hard-coded (details in comment by
> > Michael). So this is not a TripleO.
> 
> So should we change the component to OpenDaylight?

Already changed.

Comment 15 errata-xmlrpc 2018-06-27 13:38:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.