This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 150786 - load_eld_binary/exeshiled give out warnings with preempt.
load_eld_binary/exeshiled give out warnings with preempt.
Status: CLOSED DUPLICATE of bug 126342
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-10 11:35 EST by Knut J BJuland
Modified: 2015-01-04 17:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-10 15:09:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
out put off dmesg when boot into singel mode without x. (33.46 KB, text/plain)
2005-03-10 11:39 EST, Knut J BJuland
no flags Details
list of all modules loaded. (1.71 KB, text/plain)
2005-03-10 11:39 EST, Knut J BJuland
no flags Details

  None (edit)
Description Knut J BJuland 2005-03-10 11:35:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020

Description of problem:
When I recompile the last devel kernl with preemt, I get BUG: using smp_processor_id() in preemptible [00000001] code: uname/2828
caller is load_elf_binary+0xb0b/0xdc0 when I try to loas a program.


 

Version-Release number of selected component (if applicable):
2.6.11-1.1177

How reproducible:
Always

Steps to Reproduce:
1. recompile the kernel with preempt and preempt big lock, and optimase for pentium 4.
2.
3.
  

Actual Results:  BUG: using smp_processor_id() in preemptible [00000001] code: uname/2828
caller is load_elf_binary+0xb0b/0xdc0
 [<c01d2c3f>] smp_processor_id+0x8f/0xa0
 [<c0187265>] load_elf_binary+0xb0b/0xdc0
 [<c0310df2>] _spin_unlock+0x1f/0x47
 [<c014e14d>] kunmap_high+0x7b/0x9f
 [<c018675a>] load_elf_binary+0x0/0xdc0
 [<c016a283>] search_binary_handler+0xdd/0x2fe
 [<c016a608>] do_execve+0x164/0x205
 [<c0102cd6>] sys_execve+0x30/0x94
 [<c0104193>] syscall_call+0x7/0xb

Expected Results:  I should not get this error messeage.

Additional info:

There might be a patch that is misapplied patch somewhere.
Comment 1 Knut J BJuland 2005-03-10 11:39:23 EST
Created attachment 111859 [details]
out put off dmesg when boot into singel mode without x.
Comment 2 Knut J BJuland 2005-03-10 11:39:56 EST
Created attachment 111860 [details]
list of all modules loaded.
Comment 3 Dave Jones 2005-03-10 15:09:44 EST

*** This bug has been marked as a duplicate of 126342 ***

Note You need to log in before you can comment on or make changes to this bug.