Bug 1507931 - Missing cursor in GDM with latest kernel in QXL+SPICE VM
Summary: Missing cursor in GDM with latest kernel in QXL+SPICE VM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL: https://patchwork.freedesktop.org/pat...
Whiteboard: RejectedBlocker AcceptedFreezeExcepti...
Depends On:
Blocks: F27FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2017-10-31 13:31 UTC by František Zatloukal
Modified: 2017-12-01 09:06 UTC (History)
25 users (show)

Fixed In Version: kernel-4.13.16-200.fc26 kernel-4.13.16-300.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-01 03:44:09 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
i think this should fix it (115 bytes, text/plain)
2017-11-20 16:08 UTC, Ray Strode [halfline]
no flags Details
i think this should fix it (15.22 KB, application/mbox)
2017-11-20 16:11 UTC, Ray Strode [halfline]
no flags Details
round and round we go (13.39 KB, application/mbox)
2017-11-20 18:08 UTC, Ray Strode [halfline]
no flags Details
getting dizzy (15.18 KB, application/mbox)
2017-11-20 18:57 UTC, Ray Strode [halfline]
no flags Details
¯\_(ツ)_/¯ (15.19 KB, patch)
2017-11-20 20:27 UTC, Ray Strode [halfline]
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1491320 0 unspecified CLOSED heavy screen flicker with latest kernels in qxl+spice VM 2021-02-22 00:41:40 UTC

Internal Links: 1491320

Description František Zatloukal 2017-10-31 13:31:06 UTC
This is a followup of 1491320 - heavy screen flicker with latest kernels in qxl+spice VM ( https://bugzilla.redhat.com/show_bug.cgi?id=1491320 ).

Screen flickering was fixed in kernel-4.13.9-300.fc27 but the fix introduced another issue:

Cursor is missing in gdm in QXL+SPICE VM with kernel >= 4.13.9-300.fc27 . Cursor becomes visible again after login. Forcing gdm to use X11 also fixes the issue.

Testing was done using virt-manager, as gnome-boxes is using virtio by default since https://bodhi.fedoraproject.org/updates/FEDORA-2017-6db5c0829b .

Comment 1 Kamil Páral 2017-10-31 13:45:51 UTC
I can reproduce this reliably as well (it doesn't happen always that cursor is missing in gdm, but in 90% cases it does). Also, I and Frantisek noticed that if you confirm the user and then move the invisible cursor over the password prompt, the cursor is also shown immediately. I.e. the cursor change caused by the text field makes the cursor appear.

Since we don't default to virtio in virt-manager+boxes yet, proposing as a conditional blocker. When using default virtualization stacks, cursor is often missing in gdm, which makes logging in or performing certain actions (like switching a session or enabling accessibility) much more difficult (sometimes the keyboard focus seems broken and you can't reach certain widgets without the mouse).
" A system installed with a release-blocking desktop must boot to a log in screen where it is possible to log in to a working desktop using a user account created during installation or a 'first boot' utility. "
https://fedoraproject.org/wiki/Basic_Release_Criteria#Expected_installed_system_boot_behavior
"The release must be able host virtual guest instances of the same release. "
https://fedoraproject.org/wiki/Fedora_27_Beta_Release_Criteria#Self_hosting_virtualization

A workaround is available - switch your VM to virtio-vga GPU (that's harder to do in boxes).

Comment 2 Shane Overturf 2017-10-31 15:37:02 UTC
I can reproduce the invisible cursor every boot if the screen resolution is set to something higher than the default 1024x768. The cursor works normally on the gdm login screen, but as soon as the user logs in, the cursor is invisible inside the VM (works fine in the chrome). Upon moving the invisible cursor to Applications and clicking to open any application, the cursor re-appears and works normally until a reboot. If the screen resolution is set to 1024x768, the cursor never goes invisible. I thought this might be related to the need for a vertical scrollbar with the higher resolution, but sizing the window before login to force a scrollbar with 1024x768 still does not produce the invisible cursor.
Host is CentOS 7, VM is F26 running 4.13.9-200.fc26

Comment 3 Adam Williamson 2017-10-31 17:31:23 UTC
I'm kinda inclined to -1 blocker on this; it's an inconvenience but I'm not sure it's awful enough to block the release on, especially as it's fairly easy to navigate gdm with the keyboard.

Comment 4 Adam Williamson 2017-10-31 17:31:52 UTC
Shane: that sounds like the *opposite* of this bug, as this bug is described as affecting GDM but *not* the logged-in session.

Comment 5 Shane Overturf 2017-10-31 17:47:17 UTC
(In reply to Adam Williamson from comment #4)
> Shane: that sounds like the *opposite* of this bug, as this bug is described
> as affecting GDM but *not* the logged-in session.

Sorry, you are correct, I should have read it more thoroughly. I thought it might be related due to the fact that it didn't present until this kernel and some of the discussion in the flicker bug mentioned similar behaviour (i.e. mouse working in the chrome but not in the vm). I think many of the issues I see, though, are due to the host being CentOS which is slower to push the latest virt* stuff. I agree that it is only a minor inconvenience either way.

Comment 6 Adam Williamson 2017-10-31 18:26:11 UTC
Shane: it's entirely possible it's related, just wanted to note that you're not both seeing the same symptoms. We really need kernel and/or virt devs to look at this to understand exactly what's going on...

Comment 7 Jan Kurik 2017-11-01 17:33:57 UTC
I am -1 to block the F27 on this issue. As Adam already wrote, this is more an inconvenience, and even so there is a workaround.

Comment 8 Kamil Páral 2017-11-02 17:58:48 UTC
Discussed during blocker review [1]:

RejectedBlocker AcceptedFreezeException (Final) - we agreed that this doesn't really break things enough to constitute a violation of the criteria, navigating gdm with a keyboard is easy and there are workarounds like using a different video adapter. However, it's visible enough to be worth fixing if the fix is not too complex

[1] https://meetbot-raw.fedoraproject.org/fedora-meeting-1/2017-11-02/

Comment 9 Ray Strode [halfline] 2017-11-20 16:08:29 UTC
Created attachment 1355944 [details]
i think this should fix it

Comment 10 Ray Strode [halfline] 2017-11-20 16:11:15 UTC
Created attachment 1355945 [details]
i think this should fix it

(unlike attachment 1355944 [details] this one has the patch)

Comment 11 Ray Strode [halfline] 2017-11-20 17:38:33 UTC
jforbes did a scratch build here:

 https://koji.fedoraproject.org/koji/taskinfo?taskID=23262863

if someone wants to try it.

Comment 12 Ray Strode [halfline] 2017-11-20 17:39:28 UTC
eek, hang on it failed.

Comment 13 Ray Strode [halfline] 2017-11-20 18:08:08 UTC
Created attachment 1356016 [details]
round and round we go

hopefully this one will finish !

https://koji.fedoraproject.org/koji/taskinfo?taskID=23264989

Comment 14 Ray Strode [halfline] 2017-11-20 18:57:48 UTC
Created attachment 1356077 [details]
getting dizzy

nope, attachment 1356016 [details] didn't finish.

maybe this one will

https://koji.fedoraproject.org/koji/taskinfo?taskID=23266263

Comment 15 Ray Strode [halfline] 2017-11-20 20:27:48 UTC
Created attachment 1356128 [details]
¯\_(ツ)_/¯

surely it will build this time

https://koji.fedoraproject.org/koji/taskinfo?taskID=23267078

Comment 16 Kamil Páral 2017-11-21 11:14:52 UTC
(In reply to Ray Strode [halfline] from comment #15)
> https://koji.fedoraproject.org/koji/taskinfo?taskID=23267078

I see mouse cursor in gdm, seems to work.

Comment 17 Fedora Update System 2017-11-28 14:08:15 UTC
kernel-4.13.16-300.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-92a0ae09aa

Comment 18 Fedora Update System 2017-11-28 18:37:25 UTC
kernel-4.13.16-200.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f9f3d80442

Comment 19 Fedora Update System 2017-11-29 01:47:26 UTC
kernel-4.13.16-300.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-92a0ae09aa

Comment 20 Fedora Update System 2017-11-29 16:25:31 UTC
kernel-4.13.16-300.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-92a0ae09aa

Comment 21 Fedora Update System 2017-12-01 03:44:09 UTC
kernel-4.13.16-200.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2017-12-01 09:06:30 UTC
kernel-4.13.16-300.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.