Bug 1507943 - [Ansible]: lvm osd cluster installation fails when using custom cluster name
Summary: [Ansible]: lvm osd cluster installation fails when using custom cluster name
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: 3.1
Assignee: leseb
QA Contact: Ramakrishnan Periyasamy
Bara Ancincova
URL:
Whiteboard:
Keywords:
Depends On: 1635924 1266828 1459861
Blocks: 1494421
TreeView+ depends on / blocked
 
Reported: 2017-10-31 14:19 UTC by Ramakrishnan Periyasamy
Modified: 2019-01-10 16:22 UTC (History)
11 users (show)

(edit)
.Adding LVM-based OSDs fail on clusters with other names than "ceph"

An attempt to install a new Ceph cluster or add OSDs by using the `osd_scenario: lvm` parameter fails on clusters that use other names than the default "ceph". To work around this problem on new clusters, use the default cluster name ("ceph").
Clone Of:
(edit)
Last Closed: 2018-05-15 23:06:15 UTC


Attachments (Terms of Use)

Description Ramakrishnan Periyasamy 2017-10-31 14:19:05 UTC
Description of problem:

ceph-ansible fails to install lvm osd based cluster when using custom cluster name. 

Failed command: "ceph-volume lvm create --filestore --data d_vg/slow3 --journal j_vg/journal3"

failed: [magna031] (item={u'data_vg': u'd_vg', u'journal': u'journal3', u'data': u'slow3', u'journal_vg': u'j_vg'}) => {
    "changed": true, 
    "cmd": [
        "ceph-volume", 
        "lvm", 
        "create", 
        "--filestore", 
        "--data", 
        "d_vg/slow3", 
        "--journal", 
        "j_vg/journal3"
    ], 
    "delta": "0:00:00.134095", 
    "end": "2017-10-31 13:04:01.716948", 
    "failed": true, 
    "invocation": {
        "module_args": {
            "_raw_params": "ceph-volume lvm create --filestore --data d_vg/slow3 --journal j_vg/journal3", 
            "_uses_shell": false, 
            "chdir": null, 
            "creates": null, 
            "executable": null, 
            "removes": null, 
            "stdin": null, 
            "warn": true
        }
    }, 
    "item": {
        "data": "slow3", 
        "data_vg": "d_vg", 
        "journal": "journal3", 
        "journal_vg": "j_vg"
    }, 
    "msg": "non-zero return code", 
    "rc": 1, 
    "start": "2017-10-31 13:04:01.582853", 
    "stderr": "-->  NoSectionError: No section: 'global'", 
    "stderr_lines": [
        "-->  NoSectionError: No section: 'global'"
    ], 
    "stdout": "Running command: ceph-authtool --gen-print-key", 
    "stdout_lines": [
        "Running command: ceph-authtool --gen-print-key"
    ]
}

PLAY RECAP ******************************************************************************************************************************************************************
magna006                   : ok=2    changed=0    unreachable=0    failed=0   
magna028                   : ok=100  changed=5    unreachable=0    failed=0   
magna031                   : ok=53   changed=2    unreachable=0    failed=1   
magna058                   : ok=2    changed=0    unreachable=0    failed=0   
magna061                   : ok=2    changed=0    unreachable=0    failed=0   
magna063                   : ok=2    changed=0    unreachable=0    failed=0   
magna070                   : ok=2    changed=0    unreachable=0    failed=0   
magna077                   : ok=2    changed=0    unreachable=0    failed=0   
magna080                   : ok=2    changed=0    unreachable=0    failed=0   
magna086                   : ok=51   changed=1    unreachable=0    failed=0   
magna087                   : ok=53   changed=1    unreachable=0    failed=0   



Version-Release number of selected component (if applicable):
ceph: ceph version 12.2.1-34.el7cp (dcc52a7ff94884920f4118fa44a24594df9475ec) luminous (stable)
ceph-ansible: 

How reproducible:
2/2

Steps to Reproduce:
1. Configure lvm in OSD machines
2. Install cluster on lvm osd using ceph-ansible "osd_scenario='lvm'"

Actual results:


Expected results:


Additional info: It will also fail in scenario the existing cluster is configured with custom name.

Comment 3 Alfredo Deza 2017-10-31 15:16:14 UTC
Not sure why this is a 3.0 bug? This is no longer a problem in ceph-ansible master which requires the latest tip of luminous, that has this PR 

https://github.com/ceph/ceph/pull/18593

Comment 4 Christina Meno 2017-11-01 17:51:36 UTC
https://marc.info/?l=ceph-devel&m=149702444111127&w=2 says that we will be heading in a direction that custom cluster names won't be included in upstream deployment tools, this thread includes some directions on how existing cluster might migrate away from such a setup.

This work that has been done doesn't cherry-pick cleanly. I'm going to recommend that we include a release note that ceph-volume isn't supported for clusters that aren't named ceph and push this out to 3.1 as not a blocker

Comment 6 Harish NV Rao 2017-11-02 06:18:16 UTC
(In reply to Gregory Meno from comment #4)
> https://marc.info/?l=ceph-devel&m=149702444111127&w=2 says that we will be
> heading in a direction that custom cluster names won't be included in
> upstream deployment tools, this thread includes some directions on how
> existing cluster might migrate away from such a setup.
> 
> This work that has been done doesn't cherry-pick cleanly. I'm going to
> recommend that we include a release note that ceph-volume isn't supported
> for clusters that aren't named ceph and push this out to 3.1 as not a blocker

@Federico, please let us know the product's decision on this. 

Not fixing this bug in 3.0 will impact the use case of adding an lvm based osd to an existing cluster with custom cluster name. such users will not be able to use lvm feature.

Comment 11 leseb 2018-05-09 17:43:56 UTC
As per comment https://bugzilla.redhat.com/show_bug.cgi?id=1507943#c3 it seems that the issue is solved in 3.1, also this https://bugzilla.redhat.com/show_bug.cgi?id=1507943#c4 suggests no fix should be attempted on 3.0. So nothing to do for ceph-ansible.

Comment 12 Ken Dreyer (Red Hat) 2018-05-15 23:06:15 UTC
custom cluster names -> wontfix


Note You need to log in before you can comment on or make changes to this bug.