Bug 150796 - load_policy assertion failure on login
load_policy assertion failure on login
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-10 12:33 EST by Jerry James
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 16:38:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2005-03-10 12:33:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
As mentioned in https://bugzilla.redhat.com/beta/show_bug.cgi?id=149114#c10, since some RPM upgrades on Feb. 18, load_policy has been dumping core into
/etc/selinux/targeted/src/policy due to an assertion failure when I login from the console.  Logging in via ssh does not trigger the assertion failure.  The core file backtraces all look like this:

(gdb) bt
#0  0x006fe7a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x0073e955 in raise () from /lib/tls/libc.so.6
#2  0x00740319 in abort () from /lib/tls/libc.so.6
#3  0x00737f41 in __assert_fail () from /lib/tls/libc.so.6
#4  0x004d3570 in security_get_boolean_names (names=0x0, len=0xbfe22bfc)
    at booleans.c:48
#5  0x08048bc9 in main (argc=2, argv=0xbfe22d04) at load_policy.c:96
#6  0x0072be33 in __libc_start_main () from /lib/tls/libc.so.6
#7  0x08048891 in _start ()

The failed assertion is "assert(selinux_mnt);".  GDB shows that selinux_mnt is NULL.  Note that, while I have all of the selinux packages installed, selinux is disabled at boot time.

Version-Release number of selected component (if applicable):
policycoreutils-1.18.1-2.9

How reproducible:
Always

Steps to Reproduce:
1. Login from the console
2.
3.
  

Actual Results:  A new core file appears in /etc/selinux/targeted/src/policy.

Expected Results:  Something like this ought to be syslogged instead of silently failing.  I didn't even know those core files were accumulating until I stumbled across them by accident.

Additional info:
Comment 1 Daniel Walsh 2005-04-07 17:12:24 EDT
Fixed in policycoreutils-1.23.3-2 in Rawhide.

load_policy is not supposed to be run on a disabled SELinux kernel, so will not
fix in FC3.  Will be in FC4. 


Note You need to log in before you can comment on or make changes to this bug.