Bug 1507966
| Summary: | Wake up from hibernation failed:cannot serialize None | ||||||
|---|---|---|---|---|---|---|---|
| Product: | [oVirt] ovirt-engine | Reporter: | Petr Matyáš <pmatyas> | ||||
| Component: | BLL.Virt | Assignee: | Michal Skrivanek <michal.skrivanek> | ||||
| Status: | CLOSED DUPLICATE | QA Contact: | meital avital <mavital> | ||||
| Severity: | high | Docs Contact: | |||||
| Priority: | unspecified | ||||||
| Version: | 4.2.0 | CC: | bugs, mkalfon, pmatyas | ||||
| Target Milestone: | --- | Keywords: | Automation, AutomationBlocker, Regression | ||||
| Target Release: | --- | ||||||
| Hardware: | Unspecified | ||||||
| OS: | Unspecified | ||||||
| Whiteboard: | |||||||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |||||
| Doc Text: | Story Points: | --- | |||||
| Clone Of: | Environment: | ||||||
| Last Closed: | 2017-11-01 09:45:00 UTC | Type: | Bug | ||||
| Regression: | --- | Mount Type: | --- | ||||
| Documentation: | --- | CRM: | |||||
| Verified Versions: | Category: | --- | |||||
| oVirt Team: | Virt | RHEL 7.3 requirements from Atomic Host: | |||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||
| Embargoed: | |||||||
| Attachments: |
|
||||||
Does it happen only when run via run once? *** Bug 1507884 has been marked as a duplicate of this bug. *** Yes, only happens for VMs started with run once. *** This bug has been marked as a duplicate of bug 1507884 *** |
Created attachment 1345975 [details] engine log and vdsm logs Description of problem: Starting hibernated VM fails when VM was started with run once. The VM is then restarted on different host, which is not wrong, but guest agent hibernation hooks are not executed as the VM was only restarted and not hibernated from the new hosts point of view. Also the previous host is set to state Error as it failed to run a VM. Version-Release number of selected component (if applicable): ovirt-engine-4.2.0-0.0.master.20171030210714.gitef6bb9c.el7.centos.noarch How reproducible: always Steps to Reproduce: 1. run once a VM 2. suspend that VM 3. run that VM Actual results: VM fails to run and shuts down Expected results: VM starts and hibernation hooks are executed correctly Additional info: