Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1507966

Summary: Wake up from hibernation failed:cannot serialize None
Product: [oVirt] ovirt-engine Reporter: Petr Matyáš <pmatyas>
Component: BLL.VirtAssignee: Michal Skrivanek <michal.skrivanek>
Status: CLOSED DUPLICATE QA Contact: meital avital <mavital>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.2.0CC: bugs, mkalfon, pmatyas
Target Milestone: ---Keywords: Automation, AutomationBlocker, Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-01 09:45:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Virt RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
engine log and vdsm logs none

Description Petr Matyáš 2017-10-31 15:15:17 UTC
Created attachment 1345975 [details]
engine log and vdsm logs

Description of problem:
Starting hibernated VM fails when VM was started with run once. The VM is then restarted on different host, which is not wrong, but guest agent hibernation hooks are not executed as the VM was only restarted and not hibernated from the new hosts point of view.
Also the previous host is set to state Error as it failed to run a VM.

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.0-0.0.master.20171030210714.gitef6bb9c.el7.centos.noarch

How reproducible:
always

Steps to Reproduce:
1. run once a VM
2. suspend that VM
3. run that VM

Actual results:
VM fails to run and shuts down

Expected results:
VM starts and hibernation hooks are executed correctly

Additional info:

Comment 1 Yaniv Kaul 2017-11-01 08:06:21 UTC
Does it happen only when run via run once?

Comment 2 Yaniv Kaul 2017-11-01 08:07:52 UTC
*** Bug 1507884 has been marked as a duplicate of this bug. ***

Comment 3 Petr Matyáš 2017-11-01 08:14:51 UTC
Yes, only happens for VMs started with run once.

Comment 4 Yaniv Kaul 2017-11-01 09:45:00 UTC

*** This bug has been marked as a duplicate of bug 1507884 ***