Bug 150797 - Pango Firefox can't find certain glyphs
Pango Firefox can't find certain glyphs
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2005-03-10 12:46 EST by Nicholas Miell
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-04 17:36:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Incorrect rendering of kottke.org (4.86 KB, image/png)
2005-03-10 12:46 EST, Nicholas Miell
no flags Details
Correct rendering of kottke.org (4.63 KB, image/png)
2005-03-10 12:47 EST, Nicholas Miell
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 145275 None None None Never

  None (edit)
Description Nicholas Miell 2005-03-10 12:46:25 EST
When viewing kottke.org with Pango-enabled Firefox, the generic
glyph-can't-be-found-numbers-in-boxes glyph is displayed for U+2009 THIN SPACE
instead of the actual glyph.

Displaying the page in Firefox with MOZ_DISABLE_PANGO set results in an actual
space.

Viewing U+2009 in the GNOME Character Map also displays a space, so I do
actually have that glyph in a font somewhere that Pango can find.
Comment 1 Nicholas Miell 2005-03-10 12:46:25 EST
Created attachment 111863 [details]
Incorrect rendering of kottke.org
Comment 2 Nicholas Miell 2005-03-10 12:47:05 EST
Created attachment 111864 [details]
Correct rendering of kottke.org
Comment 3 sangu 2005-03-28 05:39:32 EST
Please Also : http://bugzilla.gnome.org/show_bug.cgi?id=157565

Nicholas Miell : What is locale?

This problem is probably pango's bug.
Comment 4 Nicholas Miell 2005-03-28 20:28:18 EST
The locale is en_US.UTF-8, but copying and pasting text from Mozilla to other
GNOME apps (gEdit) results in a missing glyph, so I'm willing to believe that
this is a Pango problem and not a Firefox problem.
Comment 5 Christopher Aillon 2005-05-04 12:19:00 EDT
Blizzard, any idea here?
Comment 6 Christopher Blizzard 2005-05-04 14:18:41 EDT
I suspect that since we're just handing off font descriptions and character data
to pango that pango isn't finding that particular glyph.  What I wonder is why
xft/fontconfig can find the glyph and pango can not.  (It's just \u2009. 
Nothing too sexy.)
Comment 7 Owen Taylor 2005-05-04 16:43:31 EDT
The Pango policy is that it will never select a font just to use
it for a whitespace character.

The plan is that it should just emulate missing space glyphs, though
that isn't currently implemented. See notes near the end of:

http://bugzilla.gnome.org/show_bug.cgi?id=145275

Note You need to log in before you can comment on or make changes to this bug.