Bug 1508033 - [UI] - URL fragment is ignored when redirected from a login
Summary: [UI] - URL fragment is ignored when redirected from a login
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Alexander Wels
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-31 17:47 UTC by Greg Sheremeta
Modified: 2017-12-20 10:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, if a user bookmarked a Administration Portal URL to a specific page (for example, networks -- http://<server>/ovirt-engine/webadmin/#networks), and the user was not logged in when accessing that bookmark, the user was redirected to the dashboard after login instead of the bookmarked page. This is now fixed.
Clone Of:
Environment:
Last Closed: 2017-12-20 10:45:56 UTC
oVirt Team: UX
rule-engine: ovirt-4.2+
gshereme: devel_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 83529 master MERGED webadmin: Allow places to be passed on login. 2017-11-02 18:27:47 UTC
oVirt gerrit 83557 master MERGED Dashboard: default page 2017-11-02 18:27:56 UTC

Description Greg Sheremeta 2017-10-31 17:47:02 UTC
Description of problem:
If you open http://<server>/ovirt-engine/webadmin/#networks and you're not logged in, you'll be redirected to the login page, then redirected back to WebAdmin page.

UI *should* automatically switch to #networks main grid.

But it currently redirects to the dashboard (or VMs, if dashboard isn't installed)

Version-Release number of selected component (if applicable):
4.2 master 20ce03ac

How reproducible:
always

Steps to Reproduce:
1. be logged out of webadmin
2. go to http://<server>/ovirt-engine/webadmin/#networks
3. log in

Actual results:
you are taken to the default page (dashboard or VMs)

Expected results:
you should get to whatever page your fragment has (i.e. if #networks, you should get the networks page)

Comment 1 Red Hat Bugzilla Rules Engine 2017-10-31 17:47:07 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Greg Sheremeta 2017-11-01 13:24:01 UTC
Removed "Regression" since this has been an issue since at least 4.0

Comment 4 rhev-integ 2017-11-02 21:08:44 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Tag 'ovirt-engine-4.2.0_beta1' doesn't contain patch 'https://gerrit.ovirt.org/83557']
gitweb: https://gerrit.ovirt.org/gitweb?p=ovirt-engine-dashboard.git;a=shortlog;h=refs/tags/ovirt-engine-4.2.0_beta1

For more info please contact: infra@ovirt.org

Comment 5 Lucie Leistnerova 2017-11-14 14:09:29 UTC
engine displays requested page (#networks, #vms, ...) after login

verified in ovirt-engine-webadmin-portal-4.2.0-0.0.master.20171113223918.git25568c3.el7.centos.noarch

Comment 6 Sandro Bonazzola 2017-12-20 10:45:56 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.