Bug 150805 - init script failure
init script failure
Status: CLOSED DUPLICATE of bug 149657
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-10 14:29 EST by Thomas Zehetbauer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-18 08:42:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Zehetbauer 2005-03-10 14:29:33 EST
postfix is perfectly fine using
  alias_database = ${default_database_type}:/etc/postfix/aliases
unfortunately /etc/init.d/postfix insists on running
  postaliases `postconf -h alias_database`
that fails in this configuration. The correct solution is to run newaliases
instead or not try to update the aliases db at all.
Comment 1 Thomas Woerner 2005-03-17 13:59:45 EST
If you modify your alias database you have to run newaliases afterwards.
Comment 2 Thomas Zehetbauer 2005-03-17 16:24:43 EST
Correct, one has to run newaliases after modifying the aliases file, so why does
/etc/init.d/postfix insist on it's broken implementation of newaliases?
Comment 3 Thomas Woerner 2005-03-18 06:08:15 EST
The postalias call is there to check if the alias_database entry is correct: 

- syntactically valid
- file/files existance
- correct permissions
- valid db files

If there is an other way to check this, then I will replace it.
Comment 4 Thomas Zehetbauer 2005-03-18 07:59:39 EST
alias_database = ${default_database_type}:/etc/postfix/aliases
is syntactically valid but causes the current initscript to fail

aliases_database is AFAIK only used by newaliases, the MTA processes use the
databases defined in alias_maps

postfix runs fine without an alias_database, even without alias_maps
Comment 5 Thomas Woerner 2005-03-18 08:42:51 EST
Ok, then this bz is the same as #149657.

*** This bug has been marked as a duplicate of 149657 ***

Note You need to log in before you can comment on or make changes to this bug.