Bug 1508080 - Review Request: golang-github-yuin-gopher-lua - GopherLua: VM and compiler for Lua in Go
Summary: Review Request: golang-github-yuin-gopher-lua - GopherLua: VM and compiler fo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jared Smith
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1508113
TreeView+ depends on / blocked
 
Reported: 2017-10-31 19:31 UTC by Robert-André Mauchin 🐧
Modified: 2018-06-14 18:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-19 19:47:28 UTC
Type: ---
jsmith.fedora: fedora-review+


Attachments (Terms of Use)

Comment 1 Jared Smith 2017-11-01 15:17:30 UTC
There are a few errors and warnings from rpmlint that should probably be fixed,
but the package is otherwise approved.


Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed



===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "MIT/X11 (BSD like)", "Unknown or generated". 83 files have
     unknown license. Detailed output of licensecheck in
     /home/jsmith/Documents/Personal/Reviews/1508080-golang-github-yuin-
     gopher-lua/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[x]: Package must own all directories that it creates.
     Note: Directories without known owners: /usr/share/gocode/src,
     /usr/share/gocode, /usr/share/gocode/src/github.com
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[x]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[x]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 0 bytes in 0 files.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[?]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in golang-
     github-yuin-gopher-lua-devel , golang-github-yuin-gopher-lua-unit-
     test-devel
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: SourceX is a working URL.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Large data in /usr/share should live in a noarch subpackage if package
     is arched.
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: golang-github-yuin-gopher-lua-devel-0-0.1.20170915giteb1c729.fc28.noarch.rpm
          golang-github-yuin-gopher-lua-unit-test-devel-0-0.1.20170915giteb1c729.fc28.x86_64.rpm
          golang-github-yuin-gopher-lua-0-0.1.20170915giteb1c729.fc28.src.rpm
golang-github-yuin-gopher-lua-devel.noarch: W: no-documentation
golang-github-yuin-gopher-lua-unit-test-devel.x86_64: W: no-documentation
golang-github-yuin-gopher-lua-unit-test-devel.x86_64: E: wrong-script-interpreter /usr/share/gocode/src/github.com/yuin/gopher-lua/_lua5.1-tests/all.lua ../lua 
golang-github-yuin-gopher-lua-unit-test-devel.x86_64: E: non-executable-script /usr/share/gocode/src/github.com/yuin/gopher-lua/_lua5.1-tests/all.lua 644 ../lua 
golang-github-yuin-gopher-lua-unit-test-devel.x86_64: E: version-control-internal-file /usr/share/gocode/src/github.com/yuin/gopher-lua/_lua5.1-tests/libs/.gitignore
golang-github-yuin-gopher-lua-unit-test-devel.x86_64: E: version-control-internal-file /usr/share/gocode/src/github.com/yuin/gopher-lua/_lua5.1-tests/libs/P1/.gitignore
3 packages and 0 specfiles checked; 4 errors, 2 warnings.




Rpmlint (installed packages)
----------------------------
sh: /usr/bin/python: No such file or directory
golang-github-yuin-gopher-lua-devel.noarch: W: invalid-url URL: https://github.com/yuin/gopher-lua <urlopen error [Errno -2] Name or service not known>
golang-github-yuin-gopher-lua-devel.noarch: W: no-documentation
golang-github-yuin-gopher-lua-unit-test-devel.x86_64: W: invalid-url URL: https://github.com/yuin/gopher-lua <urlopen error [Errno -2] Name or service not known>
golang-github-yuin-gopher-lua-unit-test-devel.x86_64: W: no-documentation
golang-github-yuin-gopher-lua-unit-test-devel.x86_64: E: wrong-script-interpreter /usr/share/gocode/src/github.com/yuin/gopher-lua/_lua5.1-tests/all.lua ../lua 
golang-github-yuin-gopher-lua-unit-test-devel.x86_64: E: non-executable-script /usr/share/gocode/src/github.com/yuin/gopher-lua/_lua5.1-tests/all.lua 644 ../lua 
golang-github-yuin-gopher-lua-unit-test-devel.x86_64: E: version-control-internal-file /usr/share/gocode/src/github.com/yuin/gopher-lua/_lua5.1-tests/libs/.gitignore
golang-github-yuin-gopher-lua-unit-test-devel.x86_64: E: version-control-internal-file /usr/share/gocode/src/github.com/yuin/gopher-lua/_lua5.1-tests/libs/P1/.gitignore
2 packages and 0 specfiles checked; 4 errors, 4 warnings.



Requires
--------
golang-github-yuin-gopher-lua-devel (rpmlib, GLIBC filtered):

golang-github-yuin-gopher-lua-unit-test-devel (rpmlib, GLIBC filtered):
    golang-github-yuin-gopher-lua-devel



Provides
--------
golang-github-yuin-gopher-lua-devel:
    golang(github.com/yuin/gopher-lua)
    golang(github.com/yuin/gopher-lua/ast)
    golang(github.com/yuin/gopher-lua/parse)
    golang(github.com/yuin/gopher-lua/pm)
    golang-github-yuin-gopher-lua-devel

golang-github-yuin-gopher-lua-unit-test-devel:
    golang-github-yuin-gopher-lua-unit-test-devel
    golang-github-yuin-gopher-lua-unit-test-devel(x86-64)



Source checksums
----------------
https://github.com/yuin/gopher-lua/archive/eb1c7299435cc746b72514f37f74a5154dfe460f/gopher-lua-eb1c729.tar.gz :
  CHECKSUM(SHA256) this package     : 09c7e746e44f27f9b13885aaa9fb2a99ff549a798bfb9718a7ea49106a642e37
  CHECKSUM(SHA256) upstream package : 09c7e746e44f27f9b13885aaa9fb2a99ff549a798bfb9718a7ea49106a642e37


Generated by fedora-review 0.6.1 (f03e4e7) last change: 2016-05-02
Command line :/usr/bin/fedora-review -b 1508080
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, Shell-api
Disabled plugins: Java, C/C++, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6

Comment 2 Robert-André Mauchin 🐧 2017-11-01 17:00:35 UTC
Thanks, I'll look into rpmlint errors.

Comment 3 Gwyn Ciesla 2017-11-06 14:27:57 UTC
(fedrepo-req-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/golang-github-yuin-gopher-lua

Comment 4 Fedora Update System 2017-11-07 09:36:33 UTC
golang-github-yuin-gopher-lua-0-0.1.20170915giteb1c729.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1f4bdb53b5

Comment 5 Fedora Update System 2017-11-07 19:14:53 UTC
golang-github-yuin-gopher-lua-0-0.1.20170915giteb1c729.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1f4bdb53b5

Comment 6 Fedora Update System 2017-12-08 11:32:24 UTC
golang-github-yuin-gopher-lua-0-0.1.20171031git609c9cd.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-5492384dcd

Comment 7 Fedora Update System 2017-12-10 00:33:13 UTC
golang-github-yuin-gopher-lua-0-0.1.20171031git609c9cd.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-5492384dcd

Comment 8 Fedora Update System 2017-12-19 19:47:28 UTC
golang-github-yuin-gopher-lua-0-0.1.20171031git609c9cd.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2018-05-26 16:05:41 UTC
golang-github-yuin-gopher-lua-0-0.1.20180314git7d7bc87.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-44b551cfed

Comment 10 Fedora Update System 2018-05-26 20:37:44 UTC
golang-github-yuin-gopher-lua-0-0.1.20180314git7d7bc87.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-44b551cfed

Comment 11 Fedora Update System 2018-06-14 18:15:27 UTC
golang-github-yuin-gopher-lua-0-0.1.20180314git7d7bc87.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.