Bug 150831 - Installer crashed (via NFS)
Installer crashed (via NFS)
Status: CLOSED DUPLICATE of bug 147358
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
http://glenwood.k12.mo.us/anacdump.txt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-10 19:47 EST by Richard K. Ingalls
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-21 17:14:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kickstart file that show the problem (1022 bytes, text/plain)
2006-03-21 14:22 EST, Dag Wieers
no flags Details

  None (edit)
Description Richard K. Ingalls 2005-03-10 19:47:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6)
Gecko/20050225 Firefox/1.0.1

Description of problem:
When installing via NFS, anaconda crashes at the stage where it begins
to install the files.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from CD
2. 'linux askmethod'
3. Choose NFS image
4. Follow the GUI "wizard"
5. Crashes when beginning to install files.
    

Actual Results:  Same error every time.

Expected Results:  Should have installed files via NFS.

Additional info:

Traceback (most recent call last):
  File "/usr/src/build/475969-i386/install//usr/lib/anaconda/gui.py",
line 1074, in handleRenderCallback
    self.currentWindow.renderCallback()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/iw/progress_gui.py",
line 242, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/src/build/475969-i386/install//usr/lib/anaconda/gui.py",
line 789, in nextClicked
    self.dispatch.gotoNext()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py",
line 171, in gotoNext
    self.moveStep()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py",
line 239, in moveStep
    rc = apply(func, self.bindArgs(args))
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/packages.py",
line 554, in turnOnFilesystems
    thefsset.createLogicalVolumes(instPath)
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/fsset.py", line
1432, in createLogicalVolumes
    entry.device.setupDevice(chroot)
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/fsset.py", line
2051, in setupDevice
    raise SystemError, "lvcreate failed for %s" %(self.name,)
SystemError: lvcreate failed for LogVol00

Local variables in innermost frame:
devPrefix: /tmp
self: <fsset.LogicalVolumeDevice instance at 0xb748f90c>
chroot: /mnt/sysimage
rc: 1280
Comment 1 Chris Lumens 2005-03-11 10:02:00 EST
What disks do you have in the machine, what is their original partition layout,
and what steps are you taking in the installer regarding partitioning?  Please
attach your original layout and the one created by the installer.
Comment 2 Chris Lumens 2005-06-21 17:14:34 EDT

*** This bug has been marked as a duplicate of 147358 ***
Comment 3 Dag Wieers 2006-03-21 14:22:22 EST
Created attachment 126420 [details]
Kickstart file that show the problem
Comment 4 Dag Wieers 2006-03-21 14:23:15 EST
I have a similar problem, albeit not using NFS but HTTP install.

File "/usr/src/build/648982-i386/install//usr/lib/anaconda/fsset.py", line 1861,
in setupDevice SystemError: lvcreate failed for swaplv

I tried lots of things. Reordering the logvol entries, changing options, almost
everything. I don't know what I did to cause this (because at one point it
worked fine).

Note You need to log in before you can comment on or make changes to this bug.