Bug 15085 - kernel update rpm md5 not OK
kernel update rpm md5 not OK
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-01 19:27 EDT by dbruno1
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-02 20:42:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dbruno1 2000-08-01 19:27:36 EDT
I curently run RedHat 6.1.   I downloaded the security update under
RHSA-2000:037-05 from your  errata site.  This  included the kernel rpm
(for i586), source, header, etc.

Before I began the upgrade, I ran an integrity check (rpm -K --nopgp
kernel*  etc.) of the downloaded files.   The rpms report out: md5 GPG NOT
OK.  I downloaded the files several times (and used a mirror for the
kernel), andthe failures are consistent.

For the heck of it, I tried to upgrade the kernel source and headers
anyway, and got a segmentation fault.  I run rpm-3.0.4-0.48.

Is this a problem with the files at your site, or am I doing something very
wrong?  This isn't my first kernel upgrade, and I followed your kernel
upgrade instructions. 

Dennis Bruno
Comment 1 Bill Nottingham 2000-08-02 12:53:21 EDT
Do you have the Red Hat GPG key in your key ring?
Comment 2 dbruno1 2000-08-02 20:42:36 EDT
I ran --nopgp.  I was  doing md5 checking only.  

In any event, I imported the keys into my ring, and ithe rpm -K ran clean.

I guess I'm confused.  I thought that running --nopgp bypassed the key check,
and just checked the md5 checksum.

Any idea on the segmentation fault when upgrading the headers and source?
Comment 3 Michael K. Johnson 2000-08-04 16:24:22 EDT
You need   --nogpg
as well as --nopgp
if you do not want to check any public keys.

Note You need to log in before you can comment on or make changes to this bug.