Bug 150852 - error on building php-4.3.10-2.4.src.rpm
error on building php-4.3.10-2.4.src.rpm
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-03-11 07:40 EST by Christoph Franke
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-03-11 08:06:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Christoph Franke 2005-03-11 07:40:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.6)
Gecko/20050223 Firefox/1.0.1

Description of problem:
I tried to upgrade my MySQL installation on a FC2 Server (amd64). I
installed the website's rpms and went on compiling a new php, which
links to the right MySQL libraries. But I didn't get the src.rpm
compiled. Here is the error message:

relocation R_X86_64_32 can not be used when making a shared object;
recompile with -fPIC
could not read symbols: Bad value
collect2: ld returned 1 exit status
make: *** [ext/imap/imap.la] Error 1
make: *** Waiting for unfinished jobs....
Fehler: Bad exit status from /var/tmp/rpm-tmp.19580 (%build)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.19580 (%build)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.rpmbuild --rebuild php-4.3.10-2.4.src.rpm

Additional info:

A rebuild of a php 5.03 src rpm didn't work either and brought up the
same error messages.
Comment 1 Joe Orton 2005-03-11 07:50:43 EST
What's the output of:

rpm -q libc-client libc-client-devel
rpm -V libc-client libc-client-devel
rpm -ql libc-client libc-client-devel | grep /usr/lib
Comment 2 Christoph Franke 2005-03-11 08:03:07 EST
rpm -q libc-client libc-client-devel
Paket libc-client ist nicht installiert

rpm -V libc-client libc-client-devel
Paket libc-client ist nicht installiert

rpm -ql libc-client libc-client-devel | grep /usr/lib

So, the package libc is not installed.
Comment 3 Christoph Franke 2005-03-11 08:03:38 EST
Sorry, meant libc-client is not installed.
Comment 4 Joe Orton 2005-03-11 08:06:29 EST
You need to install it then.  The the -devel package requires it in
FC3 and later which would prevent this failure mode.
Comment 5 Christoph Franke 2005-03-11 08:32:54 EST
Worked. Thanks.

Note You need to log in before you can comment on or make changes to this bug.