Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1508591 - subscription-manager version module should no longer report the installed version of python-rhsm
subscription-manager version module should no longer report the installed ver...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.5
Unspecified Unspecified
medium Severity low
: rc
: ---
Assigned To: Jiri Hnidek
Red Hat subscription-manager QE Team
: EasyFix, Triaged
: 1511742 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-11-01 14:12 EDT by John Sefler
Modified: 2018-04-10 05:52 EDT (History)
6 users (show)

See Also:
Fixed In Version: subscription-manager-1.20.6-1
Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 05:52:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github candlepin/subscription-manager/pull/1724 None None None 2017-11-09 12:00 EST
Red Hat Product Errata RHBA-2018:0681 None None None 2018-04-10 05:52 EDT

  None (edit)
Description John Sefler 2017-11-01 14:12:38 EDT
Description of problem:
As a consequence of the "Move python-rhsm build into subscription-manager" commit f445b6486a962d12185a5afe69e768d0a605e175, the subscription-manager version module should either...
  1. no longer report the installed rpm version of python-rhsm, or
  2. be changed to report the installed version of subscription-manager-rhsm

I vote for 1.


Version-Release number of selected component (if applicable):
[root@jsefler-rhel7 ~]# rpm -q subscription-manager subscription-manager-rhsm
subscription-manager-1.20.4-1.el7.x86_64
subscription-manager-rhsm-1.20.4-1.el7.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel7 ~]# subscription-manager version 
server type: Red Hat Subscription Management
subscription management server: 2.2.0-1
subscription management rules: 5.26
subscription-manager: 1.20.4-1.el7
python-rhsm: 0.0.0-1   <=================== LOOK HERE



Actual results:
  above

Expected results:
  I suggest removing python-rhsm: 0.0.0-1

Additional info:
Comment 2 Chris Snyder 2017-11-16 10:27:41 EST
*** Bug 1511742 has been marked as a duplicate of this bug. ***
Comment 4 Shwetha Kallesh 2017-11-29 05:01:34 EST
Verification:

Doesnot display python-rhsm version anymore , so marking bug as verified

[root@dhcp35-10 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: Unknown
subscription management rules: Unknown
subscription-manager: 1.20.7-1.el7
Comment 7 errata-xmlrpc 2018-04-10 05:52:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0681

Note You need to log in before you can comment on or make changes to this bug.