Bug 1508695 - [ceph-iscsi-config]: LUNs are not mapped to hostgroup hosts after reboot
Summary: [ceph-iscsi-config]: LUNs are not mapped to hostgroup hosts after reboot
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: iSCSI
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z3
: 3.0
Assignee: Jason Dillaman
QA Contact: mkasturi
Aron Gunn
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1494421
TreeView+ depends on / blocked
 
Reported: 2017-11-02 00:53 UTC by Jason Dillaman
Modified: 2018-05-15 18:21 UTC (History)
8 users (show)

(edit)
.Assigning LUNs and hosts to a hostgroup using the Ceph iSCSI `gwcli` utility no longer prevents access to the LUNs upon reboot of the iSCSI gateway host

Previously, after assigning Logical Unit Numbers (LUNs) and hosts to a hostgroup by using the Ceph iSCSI `gwcli` utiliy, and then rebooting the Ceph iSCSI gateway node, this would cause the LUN mappings to not restore properly for the hosts. In this release, hosts are no longer prevented access to the LUNs.
Clone Of:
(edit)
Last Closed: 2018-05-15 18:20:29 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1563 None None None 2018-05-15 18:21 UTC
Github ceph ceph-iscsi-config pull 33 None None None 2018-03-15 23:46 UTC

Description Jason Dillaman 2017-11-02 00:53:28 UTC
Description of problem:
After assigning LUNs and hosts to a hostgroup via gwcli, if the IGW host is rebooted, the LUN mappings are not properly restored for the hosts. This prevents access to the LUNs.

Version-Release number of selected component (if applicable):
2.3

How reproducible:
100%

Steps to Reproduce:
1. Assign LUNs and hosts to a hostgroup via gwcli
2. reboot the IGW host

Actual results:
The initiator hosts cannot access their assigned LUNs

Expected results:
The LUNs are available to the assigned hosts

Comment 16 errata-xmlrpc 2018-05-15 18:20:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1563


Note You need to log in before you can comment on or make changes to this bug.