Bug 150873 - ldap_get_option(API_INFO) failed
ldap_get_option(API_INFO) failed
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openldap (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-11 10:49 EST by Mauro Zago
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 04:19:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mauro Zago 2005-03-11 10:49:19 EST
Description of problem:
 Every openldap-clients tool such ldapsearch, ldapadd, ldapmodify
 crash with the following message:

 ldap_get_option(API_INFO) failed


Version-Release number of selected component (if applicable):
 Packages installed:
 - openldap-2.2.13-2
 - openldap-servers-2.2.13-2
 - openldap-devel-2.2.13-2
 - openldap-clients-2.2.13-2
 Hardware:
 - Dell PowerAdge 2550

How reproducible:
 Always

Steps to Reproduce:
1. run ldapsearch or ldapmodify or ldapadd with any option.

Actual results:
 ldap_get_option(API_INFO) failed

Expected results:
 ....an LDIF output for a ldapserch

Additional info:
 no more logs, even with higer debug level or verbose mode.
Comment 1 Jan Safranek 2007-06-20 03:19:43 EDT
I apologize for long silence from Red Hat. I am new maintainer of openldap and I
am cleaning old bugs. To me it seems the bug is caused by wrong linking of ldap
client tools with ldap libraries... but you have correct libraries installed.
Could you please try to reproduce the bug with latest RHEL 4.5 update? 

In case it fails again, attach please output of 'ldd -r /usr/bin/ldapsearch'.
Comment 2 Mauro Zago 2007-06-27 03:24:35 EDT
Sorry but it's a year that I've changed work. I do not exactly remember what
I've done.

I think I've leaved only
- openldap-2.2.13-2
- openldap-devel-2.2.13-2
and uninstalled the "-client-" and "-server-" rpm packages...

bye

Mauro
Comment 3 Jan Safranek 2007-06-27 04:19:49 EDT
Closing this bug as it is not reproduceable, even by reporter. If you encounter
this bug again, please contact Red Hat support at
http://www.redhat.com/apps/support/

Note You need to log in before you can comment on or make changes to this bug.