Bug 1508827 - Firefox fails to register packaged add-on updates
Summary: Firefox fails to register packaged add-on updates
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 28
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-02 10:11 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2018-10-31 10:50 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-31 10:50:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 1427349 None None None 2017-12-29 10:59:04 UTC

Description Dominik 'Rathann' Mierzejewski 2017-11-02 10:11:31 UTC
Description of problem:
After updating mozilla-noscript package, the running firefox instance doesn't "notice" the update. Restarting the browser doesn't help, either.

Version-Release number of selected component (if applicable):
firefox-56.0-5.fc26.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Install mozilla-noscript-5.0.9.
2. Start firefox and open about:addons.
3. Update mozilla-noscript to 5.1.1.
4. Restart firefox.

Actual results:
NoScript add-on version is still shown as 5.0.9.

Expected results:
NoScript add-on version in about:addons tab should show the updated version 5.1.1.

Additional info:
To see the correct version, the following steps are currently necessary:
1. stop firefox
2. remove mozilla-noscript-5.0.9
3. start firefox
4. stop firefox
5. install mozilla-noscript-5.1.1
6. start firefox

Comment 1 Martin Stransky 2017-11-02 10:16:53 UTC
Please try to launch with different profile (https://fedoraproject.org/wiki/How_to_debug_Firefox_problems?rd=Bug_info_Firefox#Further_troubleshooting_steps) if the new version is available there.

Also make sure the old version (5.0.9) is really uninstalled/removed from all your mozilla directories, like ~/.mozilla.

Comment 2 Dominik 'Rathann' Mierzejewski 2017-11-02 17:33:16 UTC
Yes, it's reproducible with a fresh profile, too.

Moreover, for the extension to be "noticed" by Firefox I had to restart firefox *twice* after doing a fresh installation of the mozilla-noscript package.

Comment 3 Dominik 'Rathann' Mierzejewski 2017-11-23 13:10:30 UTC
Same thing happens with mozilla-https-everywhere addon. I noticed that "Last Updated" date on the addon information tab shows correct date, but the displayed version is still wrong (previous one, not the updated one).

Comment 4 Russell Golden 2017-11-27 20:53:25 UTC
I noticed that installing HTTPS Everywhere from the EFF website, then removing that version, made the packaged XPI work.

Comment 5 Dominik 'Rathann' Mierzejewski 2017-12-29 10:59:04 UTC
Reported upstream, too.

Comment 6 Dominik 'Rathann' Mierzejewski 2018-01-29 15:33:04 UTC
Still reproducible with firefox-58.0-4.fc27.x86_64 .

Comment 7 Andre Robatino 2018-05-24 15:48:21 UTC
Still reproducible with firefox-60.0-4.fc28.x86_64.

Comment 8 Dominik 'Rathann' Mierzejewski 2018-08-06 20:32:42 UTC
I was just able to update mozilla-privacy-badger (https://bodhi.fedoraproject.org/updates/FEDORA-2018-bb965553f9) normally, i.e. using just dnf update and restarting firefox (firefox-61.0.1-3.fc28.x86_64) just once. Can anyone else confirm this?

Comment 9 Zavisa Nikac 2018-08-13 12:13:26 UTC
I have the same problem with mozilla-adblockplus-2.9.1-1 on firefox-61.0.2-1.fc28.x86_64. mozilla-noscript-10.1.8.16-2.fc28.noarch works just fine.

Comment 10 ozoder 2018-08-15 09:11:06 UTC
I can't reproduce this bug, all of the mentioned plugins update correctly. The issue with Adblock Plus might be the fact that the version 2.9.1 is not compatible with Firefox 61.

Comment 11 Zavisa Nikac 2018-08-15 11:08:13 UTC
If incompatible, why are them in the repos? BTW, note that plugin tests for firfox imply installing them all with dnf install mozilla-\*, and some of them show up as f27:
Installing:
 mozilla-adblockplus            noarch 2.9.1-1.fc27               fedora  679 k
 mozilla-fira-fonts-common      noarch 4.202-3.fc27               fedora   10 k
 mozilla-fira-mono-fonts        noarch 4.202-3.fc27               fedora  188 k
 mozilla-fira-sans-fonts        noarch 4.202-3.fc27               fedora  4.4 M
 mozilla-googlesharing          noarch 0.18-13.fc27               fedora   60 k
 mozilla-https-everywhere       noarch 2018.6.21-1.fc28           updates 4.0 M
 mozilla-lightbeam              noarch 2.1.0-1.fc28               fedora  578 k
 mozilla-noscript               noarch 10.1.8.16-2.fc28           updates  17 k
 mozilla-requestpolicy          noarch 1.0-0.19.20171019git633302.fc28
                                                                  fedora  251 k
 mozilla-ublock-origin          noarch 1.16.14-1.fc28             updates 2.1 M
Installing dependencies:
 firefox-noscript               noarch 10.1.8.16-2.fc28           updates 435 k
 fontsquirrel-crete-round-fonts noarch 0-0.3.20111222.fc28        fedora   59 k
 seamonkey-noscript             noarch 5.1.8.6-2.fc28             updates 742 k
Installing weak dependencies:
 adobe-source-sans-pro-fonts    noarch 2.020-2.fc28               fedora  709 k

Comment 12 Martin Stransky 2018-08-15 11:23:19 UTC
Moving to mozilla-adblockplus as the package needs update for recent Firefox.

Comment 13 Emma Watsun 2018-10-31 10:30:59 UTC
I have read this blog on How to Unblock Adobe Flash Player. They have mentioned your issue in their blog and provided solution also. You should read this blog.
Visit- https://www.adobesupportphonenumber.com/blog/unblock-adobe-flash-player/

Comment 14 Dominik 'Rathann' Mierzejewski 2018-10-31 10:50:26 UTC
(In reply to Martin Stransky from comment #12)
> Moving to mozilla-adblockplus as the package needs update for recent Firefox.

That's correct, but not related to this bug directly. In the meantime, it seems to have been fixed upstream between 58 and 61, so this should actually be reassigned to firefox and closed.


Note You need to log in before you can comment on or make changes to this bug.