Bug 15089 - X hangs after moving window
X hangs after moving window
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-01 21:40 EDT by Christian Rose
Modified: 2014-03-16 22:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-15 14:21:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config from after a text mode install (13.77 KB, text/plain)
2000-08-03 08:23 EDT, Christian Rose
no flags Details
XF86Config-4 from after a text mode install (1.28 KB, text/plain)
2000-08-03 08:24 EDT, Christian Rose
no flags Details
XF86Config from after a graphical install (15.49 KB, text/plain)
2000-08-03 12:41 EDT, Christian Rose
no flags Details
XF86Config-4 from after a graphical install (2.96 KB, text/plain)
2000-08-03 12:41 EDT, Christian Rose
no flags Details

  None (edit)
Description Christian Rose 2000-08-01 21:40:39 EDT
Performed text mode installs with Pinstripe, one custom and one standard
GNOME workstation. Had this problem in both.

After install when I start GNOME and try moving the gnome-hint window, X
hangs. Mouse pointer is still moveable, but nothing reacts.

Could this be related to the mouse? Contrary to previous betas, I don't get
a mouse selection dialog in the text mode install. Maybe the wrong mouse is
used?

Hardware:
CPU:    Pentium 233 MMX
Memory: 96 MB
Disk:   4.3GB IDE
Cdrom:  24x
Video:  Matrox Mystique (170 MHz ramdac, 4 MB)
NIC:    Intel Etherexpress 100+
Mouse:  Regular two-button PS/2
Comment 1 Bill Nottingham 2000-08-02 23:11:20 EDT
What does your XF86Config (or XF86Config-4) file look like?
Comment 2 Christian Rose 2000-08-03 08:22:37 EDT
I'm only having this problem after text mode installs, it seems. I get a pretty
clear picture when starting X but vertical lines (edges on windows) are
*somewhat* distorted. And as soon as I move a window with the mouse X will go to
Tomorrowland and not respond to any input (uses 98% CPU).

Will attach both the XF86Config and the XF86Config-4 file (I have both, don't
know which is the one that actually gets used) from after a text mode install.
Comment 3 Christian Rose 2000-08-03 08:23:50 EDT
Created attachment 1894 [details]
XF86Config from after a text mode install
Comment 4 Christian Rose 2000-08-03 08:24:47 EDT
Created attachment 1895 [details]
XF86Config-4 from after a text mode install
Comment 5 Christian Rose 2000-08-03 12:40:28 EDT
Attaching my XF86Config* files I get from after a graphical install, when
everything is fine and happy.
Comment 6 Christian Rose 2000-08-03 12:41:10 EDT
Created attachment 1914 [details]
XF86Config from after a graphical install
Comment 7 Christian Rose 2000-08-03 12:41:53 EDT
Created attachment 1915 [details]
XF86Config-4 from after a graphical install
Comment 8 Bill Nottingham 2000-08-06 18:51:09 EDT
What does /dev/mouse point to on your system?
Comment 9 Bill Nottingham 2000-08-06 18:52:56 EDT
You don't happen to have a USB keyboard, do you?
Comment 10 Christian Rose 2000-08-06 18:56:05 EDT
No, regular PS/2 keyboard (but connected through a keyboard/monitorswitch). The
mouse is a regular two-button PS/2 conected directly.
Will perform a text mode install again, as what I have now is a working system
from a GUI install.
Comment 11 Christian Rose 2000-08-06 20:11:41 EDT
This is from after a text mode install:
lrwxrwxrwx    1 root     root            5 aug  7  2000 /dev/mouse -> psaux
I think it looks correct?
Comment 12 Bill Nottingham 2000-08-14 17:38:10 EDT
If you use the config from after a text install, but change
/dev/mouse (in the config file) to /dev/psaux, does
that solve the problem?
Comment 13 Christian Rose 2000-08-14 20:54:48 EDT
No, changing it to /dev/psaux in either of the XF86Config files had no effect.
It still goes bazoo after I move a window.
Comment 14 Bill Nottingham 2000-08-15 11:29:39 EDT
If you re-run the Xconfigurator from RC1 (that's what's
used in text mode installs), does the problem persist?
Comment 15 Christian Rose 2000-08-15 14:21:46 EDT
Tested with Xconfigurator-4.3.44-1 (from RC1) and Xconfigurator-4.3.48-1 (from
http://people.redhat.com/teg/xc/) and both of them fix the problem.
X doesn't hang now.

Marking it as Resolved.
Comment 16 Christian Rose 2000-08-27 13:35:14 EDT
I couldn't reproduce this at all in RC2. Closing this.

Note You need to log in before you can comment on or make changes to this bug.